blob: 2b96111600c24d0627d6ba11b52f1cc7b1c30873 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Dummy package which ensures perl is excluded from buildtools"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4
Patrick Williamsf1e5d692016-03-30 15:21:19 -05005inherit allarch
Patrick Williamsc124f4f2015-09-15 14:41:29 -05006
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05007PR = "r2"
Patrick Williamsf1e5d692016-03-30 15:21:19 -05008
9python() {
10 # Put the package somewhere separate to ensure it's never used except
11 # when we want it
12 # (note that we have to do this in anonymous python here to avoid
13 # allarch.bbclass disabling itself)
14 d.setVar('PACKAGE_ARCH', 'buildtools-dummy-${SDKPKGSUFFIX}')
15}
Patrick Williamsc124f4f2015-09-15 14:41:29 -050016
17PERLPACKAGES = "nativesdk-perl \
18 nativesdk-perl-module-file-path"
19
20ALLOW_EMPTY_${PN} = "1"
21
22python populate_packages_prepend() {
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050023 d.appendVar(d.expand('RPROVIDES_${PN}'), '${PERLPACKAGES}')
24 d.appendVar(d.expand('RCONFLICTS_${PN}'), '${PERLPACKAGES}')
25 d.appendVar(d.expand('RREPLACES_${PN}'), '${PERLPACKAGES}')
Patrick Williamsc124f4f2015-09-15 14:41:29 -050026}
27