blob: 7549158317bdd69bfcbf486229ed4a1492ed2811 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001MAJOR_VERSION = "2.27"
2require util-linux.inc
3
4# To support older hosts, we need to patch and/or revert
5# some upstream changes. Only do this for native packages.
6OLDHOST = ""
7OLDHOST_class-native = "file://util-linux-native.patch \
8 file://util-linux-native-qsort.patch \
9 "
10
11SRC_URI += "file://util-linux-ng-2.16-mount_lock_path.patch \
12 file://configure-sbindir.patch \
13 file://runuser.pamd \
14 file://runuser-l.pamd \
15 ${OLDHOST} \
16 file://ptest.patch \
17 file://run-ptest \
18 file://avoid_unsupported_sleep_param.patch \
19 file://avoid_unsupported_grep_opts.patch \
20 file://display_testname_for_subtest.patch \
21 file://avoid_parallel_tests.patch \
22 file://uuid-test-error-api.patch \
23"
24SRC_URI[md5sum] = "3cd2698d1363a2c64091c2dadc974647"
25SRC_URI[sha256sum] = "0a818fcdede99aec43ffe6ca5b5388bff80d162f2f7bd4541dca94fecb87a290"
26
27CACHED_CONFIGUREVARS += "scanf_cv_alloc_modifier=ms"
28
29EXTRA_OECONF_class-native = "${SHARED_EXTRA_OECONF} \
30 --disable-fallocate \
31 --disable-use-tty-group \
32"
33EXTRA_OECONF_class-nativesdk = "${SHARED_EXTRA_OECONF} \
34 --disable-fallocate \
35 --disable-use-tty-group \
36"