blob: d77b8273e294234b647ac411916335146553f70a [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Automated text and program generation tool"
2DESCRIPTION = "AutoGen is a tool designed to simplify the creation and\
3 maintenance of programs that contain large amounts of repetitious text.\
4 It is especially valuable in programs that have several blocks of text\
5 that must be kept synchronized."
6HOMEPAGE = "http://www.gnu.org/software/autogen/"
7SECTION = "devel"
8LICENSE = "GPLv3"
9LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
10
11SRC_URI = "${GNU_MIRROR}/autogen/rel${PV}/autogen-${PV}.tar.gz \
12 file://increase-timeout-limit.patch \
13 file://mk-tpl-config.sh-force-exit-value-to-be-0-in-subproc.patch \
14 file://redirect-output-dir.patch \
15"
16
17SRC_URI[md5sum] = "fdee403e524c0af3ded6b3becb365671"
18SRC_URI[sha256sum] = "2fc7f12a5ecb3b1e8bd4364aa906b837cff01f80edb7d2fb38ed8b9dfbcd3271"
19
20UPSTREAM_CHECK_URI = "http://ftp.gnu.org/gnu/autogen/"
21UPSTREAM_CHECK_REGEX = "rel(?P<pver>\d+(\.\d+)+)/"
22
23DEPENDS = "guile-native libtool-native libxml2-native"
24
25inherit autotools texinfo native pkgconfig
26
27# autogen-native links against libguile which may have been relocated with sstate
28# these environment variables ensure there isn't a relocation issue
29export GUILE_LOAD_PATH = "${STAGING_DATADIR_NATIVE}/guile/2.0"
30export GUILE_LOAD_COMPILED_PATH = "${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache"
31
32do_install_append () {
33 create_wrapper ${D}/${bindir}/autogen \
34 GUILE_LOAD_PATH=${STAGING_DATADIR_NATIVE}/guile/2.0 \
35 GUILE_LOAD_COMPILED_PATH=${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache
36}