blob: cffcd885aac330b3c8461d78b48dbce33c42a605 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "GNU Project parser generator (yacc replacement)"
2DESCRIPTION = "Bison is a general-purpose parser generator that converts an annotated context-free grammar into \
3an LALR(1) or GLR parser for that grammar. Bison is upward compatible with Yacc: all properly-written Yacc \
4grammars ought to work with Bison with no change. Anyone familiar with Yacc should be able to use Bison with \
5little trouble."
6HOMEPAGE = "http://www.gnu.org/software/bison/"
7LICENSE = "GPLv3"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
9SECTION = "devel"
10DEPENDS = "bison-native flex-native"
11
12SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.xz \
13 file://m4.patch \
14 file://0001-Unset-need_charset_alias-when-building-for-musl.patch \
15 file://dont-depend-on-help2man.patch.patch \
16 file://0001-src-local.mk-fix-parallel-issue.patch \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050017 file://add-with-bisonlocaledir.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050018"
19
20# No point in hardcoding path to m4, just use PATH
21EXTRA_OECONF += "M4=m4"
22
23SRC_URI[md5sum] = "c342201de104cc9ce0a21e0ad10d4021"
24SRC_URI[sha256sum] = "a72428c7917bdf9fa93cb8181c971b6e22834125848cf1d03ce10b1bb0716fe1"
25
26LDFLAGS_prepend_libc-uclibc = " -lrt "
27DEPENDS_class-native = "gettext-minimal-native"
28
29inherit autotools gettext texinfo
30acpaths = "-I ${S}/m4"
31
32do_compile_prepend() {
33 for i in mfcalc calc++ rpcalc; do mkdir -p ${B}/examples/$i; done
34}
35
36do_install_append_class-native() {
37 create_wrapper ${D}/${bindir}/bison \
38 BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison
39}
40BBCLASSEXTEND = "native nativesdk"