blob: 32e7bae5877fed673b3a193486aaa7ef2049ed0b [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Checksumming Copy on Write Filesystem utilities"
2DESCRIPTION = "Btrfs is a new copy on write filesystem for Linux aimed at \
3implementing advanced features while focusing on fault tolerance, repair and \
4easy administration. \
5This package contains utilities (mkfs, fsck, btrfsctl) used to work with \
6btrfs and an utility (btrfs-convert) to make a btrfs filesystem from an ext3."
7
8HOMEPAGE = "https://btrfs.wiki.kernel.org"
9
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067"
12SECTION = "base"
13DEPENDS = "util-linux attr e2fsprogs lzo acl"
14RDEPENDS_${PN} = "libgcc"
15
16SRCREV = "21258fab2caeade405a15ba932d373b364aa6e8c"
17SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git \
18 file://fix-parallel.patch \
19 file://fix-symlink-creation-multiple-times.patch \
20"
21
22inherit autotools-brokensep pkgconfig
23
24EXTRA_OECONF += "--disable-documentation"
25EXTRA_OECONF_append_libc-musl = " --disable-backtrace "
26
27
28do_configure_prepend() {
29 sh autogen.sh
30}
31
32S = "${WORKDIR}/git"
33
34BBCLASSEXTEND = "native"