blob: 4964c0507854d5ecb202e6b95e13d4151ad3b5af [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Utilities and libraries for handling compiled object files"
2HOMEPAGE = "https://fedorahosted.org/elfutils"
3SECTION = "base"
4LICENSE = "(GPLv3 & Elfutils-Exception)"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6DEPENDS = "libtool bzip2 zlib virtual/libintl"
7DEPENDS_append_libc-musl = " argp-standalone fts "
8
9SRC_URI = "https://fedorahosted.org/releases/e/l/elfutils/${PV}/${BP}.tar.bz2"
10
11SRC_URI[md5sum] = "2e4536c1c48034f188a80789a59114d8"
12SRC_URI[sha256sum] = "9683c025928a12d06b7fe812928aa6235249e22d197d086f7084606a48165900"
13
14SRC_URI += "\
15 file://dso-link-change.patch \
16 file://Fix_elf_cvt_gunhash.patch \
17 file://fixheadercheck.patch \
18 file://0001-elf_getarsym-Silence-Werror-maybe-uninitialized-fals.patch \
19 file://0001-remove-the-unneed-checking.patch \
20 file://0001-fix-a-stack-usage-warning.patch \
21 file://aarch64_uio.patch \
22 file://shadow.patch \
23"
24
25# pick the patch from debian
26# http://ftp.de.debian.org/debian/pool/main/e/elfutils/elfutils_0.164-1.debian.tar.xz
27SRC_URI += "\
28 file://hppa_backend.diff \
29 file://arm_backend.diff \
30 file://mips_backend.diff \
31 file://m68k_backend.diff \
32 file://testsuite-ignore-elflint.diff \
33 file://mips_readelf_w.patch \
34 file://kfreebsd_path.patch \
35 file://0001-Ignore-differences-between-mips-machine-identifiers.patch \
36 file://0002-Add-support-for-mips64-abis-in-mips_retval.c.patch \
37 file://0003-Add-mips-n64-relocation-format-hack.patch \
38 file://uclibc-support.patch \
39"
40SRC_URI_append_libc-musl = " file://0001-build-Provide-alternatives-for-glibc-assumptions-hel.patch "
41
42# The buildsystem wants to generate 2 .h files from source using a binary it just built,
43# which can not pass the cross compiling, so let's work around it by adding 2 .h files
44# along with the do_configure_prepend()
45
46inherit autotools gettext
47
48EXTRA_OECONF = "--program-prefix=eu- --without-lzma"
49EXTRA_OECONF_append_class-native = " --without-bzlib"
50EXTRA_OECONF_append_libc-uclibc = " --enable-uclibc"
51
52do_install_append() {
53 if [ "${TARGET_ARCH}" != "x86_64" ] && [ -z `echo "${TARGET_ARCH}"|grep 'i.86'` ];then
54 rm -f ${D}${bindir}/eu-objdump
55 fi
56}
57
58# we can not build complete elfutils when using uclibc
59# but some recipes e.g. gcc 4.5 depends on libelf so we
60# build only libelf for uclibc case
61
62EXTRA_OEMAKE_libc-uclibc = "-C libelf"
63EXTRA_OEMAKE_class-native = ""
64EXTRA_OEMAKE_class-nativesdk = ""
65
66ALLOW_EMPTY_${PN}_libc-musl = "1"
67
68BBCLASSEXTEND = "native nativesdk"
69
70# Package utilities separately
71PACKAGES =+ "${PN}-binutils libelf libasm libdw"
72FILES_${PN}-binutils = "\
73 ${bindir}/eu-addr2line \
74 ${bindir}/eu-ld \
75 ${bindir}/eu-nm \
76 ${bindir}/eu-readelf \
77 ${bindir}/eu-size \
78 ${bindir}/eu-strip"
79
80FILES_libelf = "${libdir}/libelf-${PV}.so ${libdir}/libelf.so.*"
81FILES_libasm = "${libdir}/libasm-${PV}.so ${libdir}/libasm.so.*"
82FILES_libdw = "${libdir}/libdw-${PV}.so ${libdir}/libdw.so.* ${libdir}/elfutils/lib*"
83# Some packages have the version preceeding the .so instead properly
84# versioned .so.<version>, so we need to reorder and repackage.
85#FILES_${PN} += "${libdir}/*-${PV}.so ${base_libdir}/*-${PV}.so"
86#FILES_SOLIBSDEV = "${libdir}/libasm.so ${libdir}/libdw.so ${libdir}/libelf.so"
87
88# The package contains symlinks that trip up insane
89INSANE_SKIP_${MLPREFIX}libdw = "dev-so"