blob: b4dfe157ce023b2192df210d3bdf1a2c19567a09 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "tool for automating interactive applications according to a script"
2DESCRIPTION = "Expect is a tool for automating interactive applications according to a script. \
3Following the script, Expect knows what can be expected from a program and what \
4the correct response should be. Expect is also useful for testing these same \
5applications. And by adding Tk, you can also wrap interactive applications in \
6X11 GUIs. An interpreted language provides branching and high-level control \
7structures to direct the dialogue. In addition, the user can take control and \
8interact directly when desired, afterward returning control to the script. \
9"
10HOMEPAGE = "http://sourceforge.net/projects/expect/"
11LICENSE = "PD"
12SECTION = "devel"
13
14LIC_FILES_CHKSUM = "file://license.terms;md5=fbf2de7e9102505b1439db06fc36ce5c"
15
16DEPENDS += "tcl"
17RDEPENDS_${PN} = "tcl"
18
19inherit autotools
20
21PR = "r1"
22
23SRC_URI = "${SOURCEFORGE_MIRROR}/expect/Expect/${PV}/${BPN}${PV}.tar.gz \
24 file://0001-configure.in.patch \
25 file://0002-tcl.m4.patch \
26 file://01-example-shebang.patch \
27 file://0001-expect-install-scripts-without-using-the-fixline1-tc.patch \
28 "
29SRC_URI[md5sum] = "44e1a4f4c877e9ddc5a542dfa7ecc92b"
30SRC_URI[sha256sum] = "b28dca90428a3b30e650525cdc16255d76bb6ccd65d448be53e620d95d5cc040"
31
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050032UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/expect/files/Expect/"
33UPSTREAM_CHECK_REGEX = "/Expect/(?P<pver>(\d+[\.\-_]*)+)/"
34
Patrick Williamsc124f4f2015-09-15 14:41:29 -050035S = "${WORKDIR}/${BPN}${PV}"
36
37do_install_append() {
38 install -d ${D}${libdir}
39 install -m 0755 ${D}${libdir}/expect${PV}/libexpect*.so ${D}${libdir}/
40 install -m 0755 ${S}/fixline1 ${D}${libdir}/expect${PV}/
41 install -m 0755 ${S}/example/* ${D}${libdir}/expect${PV}/
42 rm ${D}${libdir}/expect${PV}/libexpect*.so
43 sed -e 's|$dir|${libdir}|' -i ${D}${libdir}/expect${PV}/pkgIndex.tcl
44}
45
46EXTRA_OECONF += "--with-tcl=${STAGING_LIBDIR} \
47 --with-tclinclude=${STAGING_INCDIR}/tcl8.6 \
48 --enable-shared \
49 --enable-threads \
50 --disable-rpath \
51 "
52EXTRA_OEMAKE_install = " 'SCRIPTS=' "
53
Patrick Williamsc124f4f2015-09-15 14:41:29 -050054FILES_${PN}-dev = "${libdir_native}/expect${PV}/libexpect*.so \
55 ${includedir}/expect.h \
56 ${includedir}/expect_tcl.h \
57 ${includedir}/expect_comm.h \
58 ${includedir}/tcldbg.h \
59 ${includedir}/*.h \
60 "
61
62FILES_${PN} += "${libdir}/libexpect${PV}.so \
63 ${libdir}/expect${PV}/* \
64 "