blob: f897e1213ef8401755052038f5dbb3d7eb4a8c4f [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001require gdb.inc
2require gdb-${PV}.inc
3
4inherit python-dir
5
6do_configure_prepend() {
7 if [ -n "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then
8 cat > ${WORKDIR}/python << EOF
9#!/bin/sh
10case "\$2" in
11 --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}/" ;;
12 --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}" ;;
13 --exec-prefix) echo "${exec_prefix}" ;;
14 *) exit 1 ;;
15esac
16exit 0
17EOF
18 chmod +x ${WORKDIR}/python
19 fi
20}