blob: 232b0c37a206abf438ed57480fbe4b6d6b874237 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Program for creating simple man pages"
2SECTION = "devel"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
5DEPENDS = "autoconf-native automake-native"
6
7SRC_URI = "${GNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.xz"
8
9SRC_URI[md5sum] = "d1d44a7a7b2bd61755a2045d96ecaea0"
10SRC_URI[sha256sum] = "c232af6475ef65bee02770862a362f4c4c2e6c9967d39e987eb94cadcfc13856"
11
12inherit autotools native
13
14EXTRA_OECONF = "--disable-nls"
15
16# We don't want to reconfigure things as it would require 'perlnative' to be
17# used.
18do_configure() {
19 oe_runconf
20}
21
22do_install_append () {
23 # Make sure we use /usr/bin/env perl
24 sed -i -e "1s:#!.*:#! /usr/bin/env perl:" ${D}${bindir}/help2man
25}