blob: 577f495344c6d6271384a70fae5da694d95f3d01 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Open Package Manager"
2SUMMARY_libopkg = "Open Package Manager library"
3SECTION = "base"
4HOMEPAGE = "http://code.google.com/p/opkg/"
5BUGTRACKER = "http://code.google.com/p/opkg/issues/list"
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
8 file://src/opkg.c;beginline=2;endline=21;md5=90435a519c6ea69ef22e4a88bcc52fa0"
9
10DEPENDS = "libarchive"
11
12PE = "1"
13
14SRC_URI = "http://downloads.yoctoproject.org/releases/${BPN}/${BPN}-${PV}.tar.gz \
15 file://opkg-configure.service \
16 file://opkg.conf \
17 file://0001-opkg_conf-create-opkg.lock-in-run-instead-of-var-run.patch \
18 file://0001-libsolv_solver_set_arch_policy-use-correct-logic-dur.patch \
19 file://0001-configure.ac-use-pkg-config-for-libsolv.patch \
20"
21
22SRC_URI[md5sum] = "43735e5dc1ebf46bd6ce56a7cdfdc720"
23SRC_URI[sha256sum] = "d2c6c02a8384ec21168a1f0a186cb5e9f577d1452f491d02ed3e56b2ea8b87df"
24
25inherit autotools pkgconfig systemd
26
27SYSTEMD_SERVICE_${PN} = "opkg-configure.service"
28
29target_localstatedir := "${localstatedir}"
30OPKGLIBDIR = "${target_localstatedir}/lib"
31
32PACKAGECONFIG ??= ""
33
34PACKAGECONFIG[gpg] = "--enable-gpg,--disable-gpg,gpgme libgpg-error,gnupg"
35PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl"
36PACKAGECONFIG[ssl-curl] = "--enable-ssl-curl,--disable-ssl-curl,curl openssl"
37PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
38PACKAGECONFIG[sha256] = "--enable-sha256,--disable-sha256"
39PACKAGECONFIG[pathfinder] = "--enable-pathfinder,--disable-pathfinder,pathfinder"
40PACKAGECONFIG[libsolv] = "--enable-solver=libsolv,--disable-solver,libsolv"
41
42do_install_append () {
43 install -d ${D}${sysconfdir}/opkg
44 install -m 0644 ${WORKDIR}/opkg.conf ${D}${sysconfdir}/opkg/opkg.conf
45 echo "option lists_dir ${OPKGLIBDIR}/opkg/lists" >>${D}${sysconfdir}/opkg/opkg.conf
46
47 # We need to create the lock directory
48 install -d ${D}${OPKGLIBDIR}/opkg
49
50 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)};then
51 install -d ${D}${systemd_unitdir}/system
52 install -m 0644 ${WORKDIR}/opkg-configure.service ${D}${systemd_unitdir}/system/
53 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
54 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
55 -e 's,@BINDIR@,${bindir},g' \
56 -e 's,@SYSTEMD_UNITDIR@,${systemd_unitdir},g' \
57 ${D}${systemd_unitdir}/system/opkg-configure.service
58 fi
59}
60
61RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-arch-config run-postinsts libarchive"
62RDEPENDS_${PN}_class-native = ""
63RDEPENDS_${PN}_class-nativesdk = ""
64RREPLACES_${PN} = "opkg-nogpg opkg-collateral"
65RCONFLICTS_${PN} = "opkg-collateral"
66RPROVIDES_${PN} = "opkg-collateral"
67
68PACKAGES =+ "libopkg"
69
70FILES_libopkg = "${libdir}/*.so.* ${OPKGLIBDIR}/opkg/"
71FILES_${PN} += "${systemd_unitdir}/system/"
72
73BBCLASSEXTEND = "native nativesdk"
74
75CONFFILES_${PN} = "${sysconfdir}/opkg/opkg.conf"