blob: a887c037d3e3654b5acc04634ca3a731ea4d1de3 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Security-focused ELF files checking tool"
2DESCRIPTION = "This is a small set of various PaX aware and related \
3utilities for ELF binaries. It can check ELF binary files and running \
4processes for issues that might be relevant when using ELF binaries \
5along with PaX, such as non-PIC code or executable stack and heap."
6HOMEPAGE = "http://www.gentoo.org/proj/en/hardened/pax-utils.xml"
7LICENSE = "GPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
9
10SRC_URI = "http://gentoo.osuosl.org/distfiles/pax-utils-${PV}.tar.xz \
11"
12
13SRC_URI[md5sum] = "bc3614322eaf88f167a608ae85d6b207"
14SRC_URI[sha256sum] = "2945b3e4df2e0dc95800bfbd3d88ab2243b2ee4ff064bbfc75734f6d9d986a89"
15
16RDEPENDS_${PN} += "bash"
17
18do_configure_prepend() {
19 touch ${S}/NEWS ${S}/AUTHORS ${S}/ChangeLog ${S}/README
20}
21
22do_install() {
23 oe_runmake PREFIX=${D}${prefix} DESTDIR=${D} install
24}
25
26BBCLASSEXTEND = "native"
27
28inherit autotools pkgconfig
29
30PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', 'largefile', '', d)} \
31"
32PACKAGECONFIG[libcap] = "--with-caps, --without-caps, libcap"
33PACKAGECONFIG[libseccomp] = "--with-seccomp, --without-seccomp, libseccomp"
34PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
35PACKAGECONFIG[pyelftools] = "--with-python, --without-python,, pyelftools"