blob: c1720392310032f51e13b92c108a4a234045cb39 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001require python-setuptools.inc
2
3PROVIDES = "python-distribute"
4
5DEPENDS += "python"
6DEPENDS_class-native += "python-native"
7
8inherit distutils
9
10DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages"
11
12RDEPENDS_${PN} = "\
13 python-stringold \
14 python-email \
15 python-shell \
16 python-distutils \
17 python-compression \
18 python-pkgutil \
19 python-plistlib \
20 python-numbers \
21 python-html \
22 python-netserver \
23 python-ctypes \
24 python-subprocess \
25 python-unittest \
26 python-compile \
27"
28
29RDEPENDS_${PN}_class-native = "\
30 python-distutils \
31 python-compression \
32"
33
34RREPLACES_${PN} = "python-distribute"
35RPROVIDES_${PN} = "python-distribute"
36RCONFLICTS_${PN} = "python-distribute"
37
38BBCLASSEXTEND = "native nativesdk"