blob: fb2931c3f2b6b200c8ea491e0ecd786e7772330b [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001require python-setuptools.inc
2
3DEPENDS += "python3"
4DEPENDS_class-native += "python3-native"
5
6inherit distutils3
7
8DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages"
9
10# The installer puts the wrong path in the setuptools.pth file. Correct it.
11do_install_append() {
12 rm ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
13 mv ${D}${bindir}/easy_install ${D}${bindir}/easy3_install
14 echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
15}
16
17RDEPENDS_${PN} = "\
18 python3-distutils \
19 python3-compression \
20"
21RDEPENDS_${PN}_class-target = "\
22 python3-ctypes \
23 python3-distutils \
24 python3-email \
25 python3-importlib \
26 python3-numbers \
27 python3-compression \
28 python3-shell \
29 python3-subprocess \
30 python3-textutils \
31 python3-pkgutil \
32 python3-threading \
33 python3-misc \
34 python3-unittest \
35 python3-xml \
36"
37BBCLASSEXTEND = "native"