blob: 606f153623b843896e6e5b40f709fd274f5dce6d [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001require python.inc
2DEPENDS = "python-native libffi bzip2 db gdbm openssl readline sqlite3 zlib"
3PR = "${INC_PR}"
4
5DISTRO_SRC_URI ?= "file://sitecustomize.py"
6DISTRO_SRC_URI_linuxstdbase = ""
7SRC_URI += "\
8 file://01-use-proper-tools-for-cross-build.patch \
9 file://03-fix-tkinter-detection.patch \
10 file://06-avoid_usr_lib_termcap_path_in_linking.patch \
11 ${DISTRO_SRC_URI} \
12 file://multilib.patch \
13 file://cgi_py.patch \
14 file://setup_py_skip_cross_import_check.patch \
15 file://add-md5module-support.patch \
16 file://host_include_contamination.patch \
17 file://fix_for_using_different_libdir.patch \
18 file://setuptweaks.patch \
19 file://check-if-target-is-64b-not-host.patch \
20 file://search_db_h_in_inc_dirs_and_avoid_warning.patch \
21 file://avoid_warning_about_tkinter.patch \
22 file://avoid_warning_for_sunos_specific_module.patch \
23 file://python-2.7.3-remove-bsdb-rpath.patch \
24 file://fix-makefile-for-ptest.patch \
25 file://run-ptest \
26 file://parallel-makeinst-create-bindir.patch \
27 file://use_sysroot_ncurses_instead_of_host.patch \
28 file://avoid_parallel_make_races_on_pgen.patch \
29 file://add-CROSSPYTHONPATH-for-PYTHON_FOR_BUILD.patch \
30"
31
32S = "${WORKDIR}/Python-${PV}"
33
34inherit autotools multilib_header python-dir pythonnative
35
36CONFIGUREOPTS += " --with-system-ffi "
37
38EXTRA_OECONF += "ac_cv_file__dev_ptmx=yes ac_cv_file__dev_ptc=no"
39
40do_configure_append() {
41 rm -f ${S}/Makefile.orig
42 autoreconf -Wcross --verbose --install --force --exclude=autopoint ../Python-${PV}/Modules/_ctypes/libffi
43}
44
45do_compile() {
46 # regenerate platform specific files, because they depend on system headers
47 cd ${S}/Lib/plat-linux2
48 include=${STAGING_INCDIR} ${STAGING_BINDIR_NATIVE}/python-native/python \
49 ${S}/Tools/scripts/h2py.py -i '(u_long)' \
50 ${STAGING_INCDIR}/dlfcn.h \
51 ${STAGING_INCDIR}/linux/cdrom.h \
52 ${STAGING_INCDIR}/netinet/in.h \
53 ${STAGING_INCDIR}/sys/types.h
54 sed -e 's,${STAGING_DIR_HOST},,g' -i *.py
55 cd -
56
57 # remove any bogus LD_LIBRARY_PATH
58 sed -i -e s,RUNSHARED=.*,RUNSHARED=, Makefile
59
60 if [ ! -f Makefile.orig ]; then
61 install -m 0644 Makefile Makefile.orig
62 fi
63 sed -i -e 's#^LDFLAGS=.*#LDFLAGS=${LDFLAGS} -L. -L${STAGING_LIBDIR}#g' \
64 -e 's,libdir=${libdir},libdir=${STAGING_LIBDIR},g' \
65 -e 's,libexecdir=${libexecdir},libexecdir=${STAGING_DIR_HOST}${libexecdir},g' \
66 -e 's,^LIBDIR=.*,LIBDIR=${STAGING_LIBDIR},g' \
67 -e 's,includedir=${includedir},includedir=${STAGING_INCDIR},g' \
68 -e 's,^INCLUDEDIR=.*,INCLUDE=${STAGING_INCDIR},g' \
69 -e 's,^CONFINCLUDEDIR=.*,CONFINCLUDE=${STAGING_INCDIR},g' \
70 Makefile
71 # save copy of it now, because if we do it in do_install and
72 # then call do_install twice we get Makefile.orig == Makefile.sysroot
73 install -m 0644 Makefile Makefile.sysroot
74
75 export CROSS_COMPILE="${TARGET_PREFIX}"
76 export PYTHONBUILDDIR="${B}"
77
78 oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/python-native/pgen \
79 HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python-native/python \
80 STAGING_LIBDIR=${STAGING_LIBDIR} \
81 STAGING_INCDIR=${STAGING_INCDIR} \
82 STAGING_BASELIBDIR=${STAGING_BASELIBDIR} \
83 BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
84 OPT="${CFLAGS}"
85}
86
87do_install() {
88 # make install needs the original Makefile, or otherwise the inclues would
89 # go to ${D}${STAGING...}/...
90 install -m 0644 Makefile.orig Makefile
91
92 export CROSS_COMPILE="${TARGET_PREFIX}"
93 export PYTHONBUILDDIR="${B}"
94
95 # After swizzling the makefile, we need to run the build again.
96 # install can race with the build so we have to run this first, then install
97 oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/python-native/pgen \
98 HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python-native/python \
99 CROSSPYTHONPATH=${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}/lib-dynload/ \
100 STAGING_LIBDIR=${STAGING_LIBDIR} \
101 STAGING_INCDIR=${STAGING_INCDIR} \
102 STAGING_BASELIBDIR=${STAGING_BASELIBDIR} \
103 BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
104 DESTDIR=${D} LIBDIR=${libdir}
105
106 oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/python-native/pgen \
107 HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python-native/python \
108 CROSSPYTHONPATH=${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}/lib-dynload/ \
109 STAGING_LIBDIR=${STAGING_LIBDIR} \
110 STAGING_INCDIR=${STAGING_INCDIR} \
111 STAGING_BASELIBDIR=${STAGING_BASELIBDIR} \
112 BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
113 DESTDIR=${D} LIBDIR=${libdir} install
114
115 install -m 0644 Makefile.sysroot ${D}/${libdir}/python${PYTHON_MAJMIN}/config/Makefile
116
117 if [ -e ${WORKDIR}/sitecustomize.py ]; then
118 install -m 0644 ${WORKDIR}/sitecustomize.py ${D}/${libdir}/python${PYTHON_MAJMIN}
119 fi
120
121 oe_multilib_header python${PYTHON_MAJMIN}/pyconfig.h
122}
123
124do_install_append_class-nativesdk () {
125 create_wrapper ${D}${bindir}/python2.7 PYTHONHOME='${prefix}' TERMINFO_DIRS='${sysconfdir}/terminfo:/etc/terminfo:/usr/share/terminfo:/usr/share/misc/terminfo:/lib/terminfo'
126}
127
128SSTATE_SCAN_FILES += "Makefile"
129PACKAGE_PREPROCESS_FUNCS += "py_package_preprocess"
130
131py_package_preprocess () {
132 # copy back the old Makefile to fix target package
133 install -m 0644 ${B}/Makefile.orig ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/config/Makefile
134
135 # Remove references to buildmachine paths in target Makefile and _sysconfigdata
136 sed -i -e 's:--sysroot=${STAGING_DIR_TARGET}::g' -e s:'--with-libtool-sysroot=${STAGING_DIR_TARGET}'::g \
137 ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/config/Makefile \
138 ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata.py
139}
140
141require python-${PYTHON_MAJMIN}-manifest.inc
142
143# manual dependency additions
144RPROVIDES_${PN}-core = "${PN}"
145RRECOMMENDS_${PN}-core = "${PN}-readline"
146RRECOMMENDS_${PN}-core_append_class-nativesdk = " nativesdk-python-modules"
147RRECOMMENDS_${PN}-crypt = "openssl"
148
149# package libpython2
150PACKAGES =+ "lib${BPN}2"
151FILES_lib${BPN}2 = "${libdir}/libpython*.so.*"
152
153# catch all the rest (unsorted)
154PACKAGES += "${PN}-misc"
155FILES_${PN}-misc = "${libdir}/python${PYTHON_MAJMIN}"
156RDEPENDS_${PN}-modules += "${PN}-misc"
157RDEPENDS_${PN}-ptest = "${PN}-modules"
158#inherit ptest after "require python-${PYTHON_MAJMIN}-manifest.inc" so PACKAGES doesn't get overwritten
159inherit ptest
160
161# This must come after inherit ptest for the override to take effect
162do_install_ptest() {
163 cp ${B}/Makefile ${D}${PTEST_PATH}
164 sed -e s:LIBDIR/python/ptest:${PTEST_PATH}:g \
165 -e s:LIBDIR:${libdir}:g \
166 -i ${D}${PTEST_PATH}/run-ptest
167}
168
169# catch manpage
170PACKAGES += "${PN}-man"
171FILES_${PN}-man = "${datadir}/man"
172
173BBCLASSEXTEND = "nativesdk"