blob: 8eab7e3a0d25f50176e24f1534460890d3fd3701 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001LICENSE = "GPLv2"
2LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
3 file://tests/COPYING;md5=d32239bcb673463ab874e80d47fae504 \
4 file://glob/COPYING.LIB;md5=4a770b67e6be0f60da244beb2de0fce4"
5require remake.inc
6
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05007UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+)\+dbg.+)"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008SRC_URI += "file://version-remake.texi.patch \
9 "
10SRCREV = "cf54641d50a0165bb17622b3e9770f426ccbc561"
11S = "${WORKDIR}/git"
12
13DEPENDS += "readline guile"
14# Need to add "gettext-native" dependency to remake-native.
15# By default only "gettext-minimal-native" is added
16# when inherit gettext.
17DEPENDS_class-native += "gettext-native"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050018PROVIDES += "virtual/make"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050019
20do_configure_prepend() {
21 # remove the default LINGUAS since we are not going to generate languages
22 rm ${S}/po/LINGUAS
23 touch ${S}/po/LINGUAS
24 # create config.rpath which required by configure.ac
25 ( cd ${S}; autopoint || touch config.rpath )
26}
27
28BBCLASSEXTEND = "native"