blob: 73913880203c7209bc37c705bec9f69633056479 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "System call tracing tool"
2HOMEPAGE = "http://strace.sourceforge.net"
3SECTION = "console/utils"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=124500c21e856f0912df29295ba104c7"
6
7SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.xz \
8 file://disable-git-version-gen.patch \
9 file://more-robust-test-for-m32-mx32-compile-support.patch \
10 file://update-gawk-paths.patch \
11 file://use-asm-sgidefs.h.patch \
12 file://0001-arc-metag-nios2-or1k-tile-fix-build.patch \
13 file://Makefile-ptest.patch \
14 file://0001-tests-scm_rights.c-use-libtests.patch \
15 file://0001-scm_rights-fd.test-rewrite-without-fork.patch \
16 file://0001-Move-gcc-compat-macros-to-gcc_compat.h.patch \
17 file://0001-tests-introduce-libtests.patch \
18 file://run-ptest \
19 "
20
21SRC_URI[md5sum] = "a15d2555a7febb56d00c6e1a51c655dc"
22SRC_URI[sha256sum] = "e86a5f6cd8f941f67f3e4b28f4e60f3d9185c951cf266404533210a2e5cd8152"
23
24inherit autotools ptest bluetooth
25
26RDEPENDS_${PN}-ptest += "make coreutils grep gawk sed"
27
28PACKAGECONFIG_class-target ??= "\
29 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
30"
31
32PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,${BLUEZ}"
33PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"
34
35TESTDIR = "tests"
36
37do_install_append() {
38 # We don't ship strace-graph here because it needs perl
39 rm ${D}${bindir}/strace-graph
40}
41
42do_compile_ptest() {
43 oe_runmake -C ${TESTDIR} buildtest-TESTS
44}
45
46do_install_ptest() {
47 oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR}
48 sed -i -e '/^src/s/strace.*[1-9]/ptest/' ${D}/${PTEST_PATH}/${TESTDIR}/Makefile
49}
50
51BBCLASSEXTEND = "native"