blob: a19a675c58ab623f402918ba24095420e56966c7 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Subversion (svn) version control system client"
2SECTION = "console/network"
3DEPENDS = "apr-util serf sqlite3 file"
4DEPENDS_append_class-native = " file-replacement-native"
5RDEPENDS_${PN} = "serf"
6LICENSE = "Apache-2"
7HOMEPAGE = "http://subversion.tigris.org"
8
9BBCLASSEXTEND = "native"
10
11inherit gettext pythonnative
12
13SRC_URI = "${APACHE_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
14 file://disable_macos.patch \
15 file://serf.m4-Regex-modified-to-allow-D-in-paths.patch \
16 file://0001-Fix-libtool-name-in-configure.ac.patch \
17 "
18SRC_URI[md5sum] = "243036eb28b50ce517fc228eb3250add"
19SRC_URI[sha256sum] = "8bbf6bb125003d88ee1c22935a36b7b1ab7d957e0c8b5fbfe5cb6310b6e86ae0"
20
21LIC_FILES_CHKSUM = "file://LICENSE;md5=af81ae49ba359e70626c05e9bf313709"
22
23PACKAGECONFIG[sasl] = "--with-sasl,--without-sasl,cyrus-sasl"
24PACKAGECONFIG[gnome-keyring] = "--with-gnome-keyring,--without-gnome-keyring,glib-2.0 gnome-keyring"
25
26EXTRA_OECONF = " \
27 --without-berkeley-db --without-apxs \
28 --without-swig --with-apr=${STAGING_BINDIR_CROSS} \
29 --with-apr-util=${STAGING_BINDIR_CROSS} \
30 --disable-keychain \
31 ac_cv_path_RUBY=none"
32
33inherit autotools
34
35export LDFLAGS += " -L${STAGING_LIBDIR} "
36CPPFLAGS += "-P"
37BUILD_CPPFLAGS += "-P"
38
39acpaths = "-I build/ -I build/ac-macros/"
40
41do_configure_prepend () {
42 rm -f ${S}/libtool
43 rm -f ${S}/build/libtool.m4 ${S}/build/ltmain.sh ${S}/build/ltoptions.m4 ${S}/build/ltsugar.m4 ${S}/build/ltversion.m4 ${S}/build/lt~obsolete.m4
44 rm -f ${S}/aclocal.m4
45 sed -i -e 's:with_sasl="/usr/local":with_sasl="${STAGING_DIR}":' ${S}/build/ac-macros/sasl.m4
46}
47
48#| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_ra_local/libsvn_ra_local-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_repos/libsvn_repos-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'| /usr/bin/ld: cannot find -lsvn_delta-1| collect2: ld returned 1 exit status| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_ra_svn/libsvn_ra_svn-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_ra_serf/libsvn_ra_serf-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'
49#| x86_64-linux-libtool: install: error: relink `libsvn_ra_serf-1.la' with the above command before installing it
50#| x86_64-linux-libtool: install: warning: `../../subversion/libsvn_repos/libsvn_repos-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'
51#| /home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/subversion-1.8.9/build-outputs.mk:1090: recipe for target 'install-serf-lib' failed
52#| make: *** [install-serf-lib] Error 1
53PARALLEL_MAKEINST = ""