blob: eba1139e59ff0e2d9d0a647187f80c787a3a75c9 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Userspace NFS server v3 protocol"
2SECTION = "console/network"
3LICENSE = "unfs3"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=9475885294e17c0cc0067820d042792e"
5
6# SVN support for upstream version check isn't implemented yet
7RECIPE_UPSTREAM_VERSION = "0.9.22.r497"
8RECIPE_UPSTREAM_DATE = "Oct 08, 2015"
9CHECK_DATE = "Dec 10, 2015"
10
11DEPENDS = "flex-native bison-native flex"
12DEPENDS_append_libc-musl = " libtirpc "
13DEPENDS_append_class-nativesdk += "flex-nativesdk"
14
15MOD_PV = "497"
16S = "${WORKDIR}/trunk"
17SRC_URI = "svn://svn.code.sf.net/p/unfs3/code;module=trunk;rev=${MOD_PV};protocol=http \
18 file://unfs3_parallel_build.patch \
19 file://alternate_rpc_ports.patch \
20 file://fix_pid_race_parent_writes_child_pid.patch \
21 file://fix_compile_warning.patch \
22 file://rename_fh_cache.patch \
23 file://relative_max_socket_path_len.patch \
24 file://tcp_no_delay.patch \
25 "
26SRC_URI[md5sum] = "3687acc4ee992e536472365dd99712a7"
27SRC_URI[sha256sum] = "274b43ada9c6eea1da26eb7010d72889c5278984ba0b50dff4e093057d4d64f8"
28
29BBCLASSEXTEND = "native nativesdk"
30
31inherit autotools
32EXTRA_OECONF_append_class-native = " --sbindir=${bindir}"
33CFLAGS_append_libc-musl = " -I${STAGING_INCDIR}/tirpc"
34
35# Turn off these header detects else the inode search
36# will walk entire file systems and this is a real problem
37# if you have 2 TB of files to walk in your file system
38CACHED_CONFIGUREVARS = "ac_cv_header_mntent_h=no ac_cv_header_sys_mnttab_h=no"