blob: 0cffedd660ad92c073cdf4c2f62dc48a7fc64070 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "OpenPrinting printer support - filters"
2DESCRIPTION = "Foomatic is a printer database designed to make it easier to set up \
3common printers for use with UNIX-like operating systems.\
4It provides the "glue" between a print spooler (like CUPS or lpr) and \
5the printer, by processing files sent to the printer. \
6 \
7This package consists of filters used by the printer spoolers \
8to convert the incoming PostScript data into the printer's native \
9format using a printer-specific, but spooler-independent PPD file. \
10"
11
12DEPENDS += "cups perl libxml2"
13PR = "r1"
14
15LICENSE = "GPLv2+"
16LIC_FILES_CHKSUM = "file://${WORKDIR}/foomatic-filters-${PV}/COPYING;md5=393a5ca445f6965873eca0259a17f833"
17
18SRC_URI = "http://www.openprinting.org/download/foomatic/foomatic-filters-${PV}.tar.gz"
19
Patrick Williamsc124f4f2015-09-15 14:41:29 -050020SRC_URI[md5sum] = "b05f5dcbfe359f198eef3df5b283d896"
21SRC_URI[sha256sum] = "a2e2e53e502571e88eeb9010c45a0d54671f15707ee104f5c9c22b59ea7a33e3"
22
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050023UPSTREAM_CHECK_REGEX = "foomatic-filters-(?P<pver>((\d|\d\d)\.*)+)\.tar\.gz"
24
Patrick Williamsc124f4f2015-09-15 14:41:29 -050025inherit autotools pkgconfig
26
27EXTRA_OECONF += "--disable-file-converter-check --with-file-converter=texttops"
28
29do_configure_prepend() {
30 export PERL="${bindir}/env perl"
31 export CUPS_SERVERBIN=${exec_prefix}/lib/cups # /usr/lib NOT libdir
32}
33
34do_install_append_linuxstdbase() {
35 install -d ${D}${exec_prefix}/lib/cups/filter
36 ln -sf ${bindir}/foomatic-rip ${D}${exec_prefix}/lib/cups/filter
37}
38
39FILES_${PN} += "${exec_prefix}/lib/cups/ ${exec_prefix}/lib/ppr/"