blob: 26b88c9e8c69f1489bd6d4f8102e5efd761a3c90 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001DESCRIPTION = "A development image that builds the kernel and packages that are \
2sensitive to kernel updates and version changes"
3
4# Could also be core-image-basic, but we'll keep this small for now
5require recipes-core/images/core-image-minimal.bb
6
7KERNEL_DEV_UTILS ?= "dropbear connman"
8KERNEL_DEV_TOOLS ?= "packagegroup-core-tools-profile packagegroup-core-buildessential kernel-devsrc"
9KERNEL_DEV_MODULE ?= "kernel-modules"
10
11CORE_IMAGE_EXTRA_INSTALL += "${KERNEL_DEV_MODULE} \
12 ${KERNEL_DEV_UTILS} \
13 ${KERNEL_DEV_TOOLS} \
14 "
15
16# We need extra space for things like kernel builds, etc.
17IMAGE_ROOTFS_EXTRA_SPACE_append += "+ 3000000"
18
19# Let's define our own subset to test, we can later add a on-target kernel build even!
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050020DEFAULT_TEST_SUITES = "ping ssh df connman syslog scp date parselogs"