blob: 0fcd819682c4247f0e2ec7616a45d21157a8866c [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Text file viewer similar to more"
2DESCRIPTION = "Less is a program similar to more, i.e. a terminal \
3based program for viewing text files and the output from other \
4programs. Less offers many features beyond those that more does."
5HOMEPAGE = "http://www.greenwoodsoftware.com/"
6SECTION = "console/utils"
7
8# (GPLv2+ (<< 418), GPLv3+ (>= 418)) | less
9# Including email author giving permissing to use BSD
10#
11# From: Mark Nudelman <markn@greenwoodsoftware.com>
12# To: Elizabeth Flanagan <elizabeth.flanagan@intel.com
13# Date: 12/19/11
14#
15# Hi Elizabeth,
16# Using a generic BSD license for less is fine with me.
17# Thanks,
18#
19# --Mark
20#
21
22LICENSE = "GPLv3+ | BSD-2-Clause"
23LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
24 file://LICENSE;md5=48c26a307f91af700e1f00585f215aaf"
25DEPENDS = "ncurses"
26
27SRC_URI = "http://www.greenwoodsoftware.com/${BPN}/${BPN}-${PV}.tar.gz \
28 "
29
30SRC_URI[md5sum] = "50ef46065c65257141a7340123527767"
31SRC_URI[sha256sum] = "3fa38f2cf5e9e040bb44fffaa6c76a84506e379e47f5a04686ab78102090dda5"
32
33UPSTREAM_CHECK_URI = "http://www.greenwoodsoftware.com/less/download.html"
34
35inherit autotools update-alternatives
36
37do_install () {
38 oe_runmake 'bindir=${D}${bindir}' 'mandir=${D}${mandir}' install
39}
40
41ALTERNATIVE_${PN} = "less"
42ALTERNATIVE_PRIORITY = "100"