blob: e321d479ecf6339fae68dbcd98e3443f1aea0156 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Transport-Independent RPC library"
2DESCRIPTION = "Libtirpc is a port of Suns Transport-Independent RPC library to Linux"
3SECTION = "libs/network"
4HOMEPAGE = "http://sourceforge.net/projects/libtirpc/"
5BUGTRACKER = "http://sourceforge.net/tracker/?group_id=183075&atid=903784"
6LICENSE = "BSD"
7LIC_FILES_CHKSUM = "file://COPYING;md5=f835cce8852481e4b2bbbdd23b5e47f3 \
8 file://src/netname.c;beginline=1;endline=27;md5=f8a8cd2cb25ac5aa16767364fb0e3c24"
9
10PROVIDES = "virtual/librpc"
11
12SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.bz2;name=libtirpc \
13 ${GENTOO_MIRROR}/${BPN}-glibc-nfs.tar.xz;name=glibc-nfs \
14 file://libtirpc-0.2.1-fortify.patch \
15 file://0001-Add-missing-rwlock_unlocks-in-xprt_register.patch \
16 "
17
18SRC_URI_append_libc-uclibc = " file://remove-des-functionality.patch \
19 "
20
21SRC_URI_append_libc-musl = " file://remove-des-functionality.patch \
22 file://Use-netbsd-queue.h.patch \
23 "
24
25SRC_URI[libtirpc.md5sum] = "36ce1c0ff80863bb0839d54aa0b94014"
26SRC_URI[libtirpc.sha256sum] = "5156974f31be7ccbc8ab1de37c4739af6d9d42c87b1d5caf4835dda75fcbb89e"
27SRC_URI[glibc-nfs.md5sum] = "5ae500b9d0b6b72cb875bc04944b9445"
28SRC_URI[glibc-nfs.sha256sum] = "2677cfedf626f3f5a8f6e507aed5bb8f79a7453b589d684dbbc086e755170d83"
29
30inherit autotools pkgconfig
31
32EXTRA_OECONF = "--disable-gssapi"
33
34do_configure_prepend () {
35 cp -r ${S}/../tirpc ${S}
36}
37
38do_install_append() {
39 chown root:root ${D}${sysconfdir}/netconfig
40}