blob: 378accbf11dddd4e542dda126d0d227b99cebc73 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Lightweight high-performance web server"
2HOMEPAGE = "http://www.lighttpd.net/"
3BUGTRACKER = "http://redmine.lighttpd.net/projects/lighttpd/issues"
4
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://COPYING;md5=e4dac5c6ab169aa212feb5028853a579"
7
8SECTION = "net"
9DEPENDS = "zlib libpcre"
10RDEPENDS_${PN} += " \
11 lighttpd-module-access \
12 lighttpd-module-accesslog \
13 lighttpd-module-indexfile \
14 lighttpd-module-dirlisting \
15 lighttpd-module-staticfile \
16"
17
18SRC_URI = "http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${PV}.tar.xz \
19 file://index.html.lighttpd \
20 file://lighttpd.conf \
21 file://lighttpd \
22 file://lighttpd.service \
23 file://pkgconfig.patch \
24 "
25
26SRC_URI[md5sum] = "63c7563be1c7a7a9819a51f07f1af8b2"
27SRC_URI[sha256sum] = "7eb9a1853c3d6dd5851682b0733a729ba4158d6bdff80974d5ef5f1f6887365b"
28
29PACKAGECONFIG ??= "openssl"
30PACKAGECONFIG[openssl] = "--with-openssl, --without-openssl, openssl"
31
32EXTRA_OECONF = " \
33 --without-bzip2 \
34 --without-ldap \
35 --without-lua \
36 --without-memcache \
37 --with-pcre \
38 --without-webdav-props \
39 --without-webdav-locks \
40 --disable-static \
41"
42
43inherit autotools pkgconfig update-rc.d gettext systemd
44
45INITSCRIPT_NAME = "lighttpd"
46INITSCRIPT_PARAMS = "defaults 70"
47
48SYSTEMD_SERVICE_${PN} = "lighttpd.service"
49
50do_install_append() {
51 install -d ${D}${sysconfdir}/init.d ${D}${sysconfdir}/lighttpd.d ${D}/www/pages/dav
52 install -m 0755 ${WORKDIR}/lighttpd ${D}${sysconfdir}/init.d
53 install -m 0644 ${WORKDIR}/lighttpd.conf ${D}${sysconfdir}
54 install -m 0644 ${WORKDIR}/index.html.lighttpd ${D}/www/pages/index.html
55
56 install -d ${D}${systemd_unitdir}/system
57 install -m 0644 ${WORKDIR}/lighttpd.service ${D}${systemd_unitdir}/system
58 sed -i -e 's,@SBINDIR@,${sbindir},g' \
59 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
60 -e 's,@BASE_BINDIR@,${base_bindir},g' \
61 ${D}${systemd_unitdir}/system/lighttpd.service
62 #For FHS compliance, create symbolic links to /var/log and /var/tmp for logs and temporary data
63 ln -sf ${localstatedir}/log ${D}/www/logs
64 ln -sf ${localstatedir}/tmp ${D}/www/var
65}
66
67FILES_${PN} += "${sysconfdir} /www"
68
69CONFFILES_${PN} = "${sysconfdir}/lighttpd.conf"
70
71PACKAGES_DYNAMIC += "^lighttpd-module-.*"
72
73python populate_packages_prepend () {
74 lighttpd_libdir = d.expand('${libdir}')
75 do_split_packages(d, lighttpd_libdir, '^mod_(.*)\.so$', 'lighttpd-module-%s', 'Lighttpd module for %s', extra_depends='')
76}