blob: 9a2964be192499f615dc2573e8fdc56521f6e04c [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "A library for text mode user interfaces"
2
3DESCRIPTION = "Newt is a programming library for color text mode, widget based user \
4interfaces. Newt can be used to add stacked windows, entry widgets, \
5checkboxes, radio buttons, labels, plain text fields, scrollbars, \
6etc., to text mode user interfaces. This package also contains the \
7shared library needed by programs built with newt, as well as a \
8/usr/bin/dialog replacement called whiptail. Newt is based on the \
9slang library."
10
11HOMEPAGE = "https://fedorahosted.org/newt/"
12SECTION = "libs"
13
14LICENSE = "LGPLv2"
15LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
16
17# slang needs to be >= 2.2
18DEPENDS = "slang popt"
19
20SRC_URI = "https://fedorahosted.org/releases/n/e/newt/newt-${PV}.tar.gz \
21 file://remove_slang_include.patch \
22 file://fix_SHAREDDIR.patch \
23 file://cross_ar.patch \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050024 file://Makefile.in-Add-tinfo-library-to-the-linking-librari.patch \
25 file://pie-flags.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050026"
27
28SRC_URI[md5sum] = "685721bee1a318570704b19dcf31d268"
29SRC_URI[sha256sum] = "771b0e634ede56ae6a6acd910728bb5832ac13ddb0d1d27919d2498dab70c91e"
30
31S = "${WORKDIR}/newt-${PV}"
32
33EXTRA_OECONF = "--without-tcl --without-python"
34
35inherit autotools-brokensep
36
37CLEANBROKEN = "1"
38
39export STAGING_INCDIR
40export STAGING_LIBDIR
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050041export CPPFLAGS
Patrick Williamsc124f4f2015-09-15 14:41:29 -050042
43export BUILD_SYS
44export HOST_SYS
45
46PACKAGES_prepend = "whiptail "
47
48do_configure_prepend() {
49 sh autogen.sh
50}
51
52do_compile_prepend() {
53 # Make sure the recompile is OK
54 rm -f ${B}/.depend
55}
56
57FILES_whiptail = "${bindir}/whiptail"
58
59BBCLASSEXTEND = "native"