blob: 30c00c861b7a243d07644cb947865e3d90bb440e [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Disk partition editing/resizing utility"
2HOMEPAGE = "http://www.gnu.org/software/parted/parted.html"
3LICENSE = "GPLv3+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=2f31b266d3440dd7ee50f92cf67d8e6c"
5SECTION = "console/tools"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05006DEPENDS = "ncurses readline util-linux virtual/libiconv"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05007PR = "r1"
8
9SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.xz \
10 file://no_check.patch \
11 file://syscalls.patch \
12 file://fix-doc-mandir.patch \
13 file://fix-compile-failure-while-dis.patch \
14 file://0001-Include-fcntl.h-in-platform_defs.h.patch \
15 file://0001-Unset-need_charset_alias-when-building-for-musl.patch \
16 file://run-ptest \
17 file://Makefile \
18"
19
20SRC_URI[md5sum] = "0247b6a7b314f8edeb618159fa95f9cb"
21SRC_URI[sha256sum] = "858b589c22297cacdf437f3baff6f04b333087521ab274f7ab677cb8c6bb78e4"
22
23EXTRA_OECONF = "--disable-device-mapper"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050024LDFLAGS_append_libc-uclibc = " -liconv "
Patrick Williamsc124f4f2015-09-15 14:41:29 -050025
26inherit autotools pkgconfig gettext texinfo ptest
27
28BBCLASSEXTEND = "native"
29
30do_compile_ptest() {
31 oe_runmake -C tests print-align print-max dup-clobber duplicate fs-resize
32}
33
34do_install_ptest() {
35 t=${D}${PTEST_PATH}
36 mkdir $t/build-aux
37 cp ${S}/build-aux/test-driver $t/build-aux/
38 cp -r ${S}/tests $t
39 cp ${WORKDIR}/Makefile $t/tests/
40 sed -i "s|^VERSION.*|VERSION = ${PV}|g" $t/tests/Makefile
41 for i in print-align print-max dup-clobber duplicate fs-resize; \
42 do cp ${B}/tests/.libs/$i $t/tests/; \
43 done
44 sed -e 's| ../parted||' -i $t/tests/*.sh
45}
46
47RDEPENDS_${PN}-ptest = "bash coreutils perl util-linux-losetup python"