blob: 4a980464b1c36c1e42b81b714bba01eff1c348d3 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Tools for monitoring & limiting user disk usage per filesystem"
2SECTION = "base"
3HOMEPAGE = "http://sourceforge.net/projects/linuxquota/"
4BUGTRACKER = "http://sourceforge.net/tracker/?group_id=18136&atid=118136"
5LICENSE = "BSD & GPLv2+ & LGPLv2.1+"
6LIC_FILES_CHKSUM = "file://quota.c;beginline=1;endline=33;md5=331c7d77744bfe0ad24027f0651028ec \
7 file://rquota_server.c;beginline=1;endline=20;md5=fe7e0d7e11c6f820f8fa62a5af71230f \
8 file://svc_socket.c;beginline=1;endline=17;md5=24d5a8792da45910786eeac750be8ceb"
9
10SRC_URI = "${SOURCEFORGE_MIRROR}/project/linuxquota/quota-tools/${PV}/quota-${PV}.tar.gz \
11 file://0001-Fix-build-with-disabled-ldap.patch \
12 file://0001-Do-not-accidentaly-override-commandline-passed-CFLAG.patch \
13 file://fcntl.patch \
14 file://remove_non_posix_types.patch \
15 "
16SRC_URI_append_libc-musl = " file://replace_getrpcbynumber_r.patch"
17
18SRC_URI[md5sum] = "6b09f9c93515c25a528be5754cdfb6f5"
19SRC_URI[sha256sum] = "9c6c4d9ae7bf30506dd2aa3d8056c4ff2f8d087930d7c721616f5c093bdc674b"
20
21UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/linuxquota/files/quota-tools/"
22UPSTREAM_CHECK_REGEX = "/quota-tools/(?P<pver>(\d+[\.\-_]*)+)/"
23
24DEPENDS = "gettext-native e2fsprogs libnl dbus"
25
26inherit autotools-brokensep gettext pkgconfig
27
28CFLAGS += "-I${STAGING_INCDIR}/tirpc"
29LDFLAGS += "-ltirpc"
30ASNEEDED = ""
31
32PACKAGECONFIG ??= "tcp-wrappers rpc bsd"
33PACKAGECONFIG_libc-musl = "tcp-wrappers rpc"
34
35PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers"
36PACKAGECONFIG[rpc] = "--enable-rpc,--disable-rpc,libtirpc"
37PACKAGECONFIG[bsd] = "--enable-bsd_behaviour=yes,--enable-bsd_behaviour=no,"
38PACKAGECONFIG[ldapmail] = "--enable-ldapmail,--disable-ldapmail,openldap"