blob: c19a1976a1bdaeafafdaf0b341098423d95606b7 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Universal Addresses to RPC Program Number Mapper"
2DESCRIPTION = "The rpcbind utility is a server that converts RPC \
3 program numbers into universal addresses."
4SECTION = "console/network"
5HOMEPAGE = "http://sourceforge.net/projects/rpcbind/"
6BUGTRACKER = "http://sourceforge.net/tracker/?group_id=201237&atid=976751"
7DEPENDS = "libtirpc quota"
8
9LICENSE = "BSD"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b46486e4c4a416602693a711bb5bfa39 \
11 file://src/rpcinfo.c;beginline=1;endline=27;md5=f8a8cd2cb25ac5aa16767364fb0e3c24"
12
13SRC_URI = "${SOURCEFORGE_MIRROR}/rpcbind/rpcbind-${PV}.tar.bz2 \
14 file://init.d \
15 file://0001-Avoid-use-of-glibc-sys-cdefs.h-header.patch \
16 file://remove-sys-queue.patch \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050017 file://0001-handle_reply-Don-t-use-the-xp_auth-pointer-directly.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050018 ${UCLIBCPATCHES} \
19 ${MUSLPATCHES} \
20 file://rpcbind.conf \
21 file://rpcbind.socket \
22 file://rpcbind.service \
Patrick Williamsf1e5d692016-03-30 15:21:19 -050023 file://cve-2015-7236.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050024 "
25MUSLPATCHES_libc-musl = "file://musl-sunrpc.patch"
26
Patrick Williamsc124f4f2015-09-15 14:41:29 -050027UCLIBCPATCHES ?= ""
28MUSLPATCHES ?= ""
29
30SRC_URI[md5sum] = "c8875246b2688a1adfbd6ad43480278d"
31SRC_URI[sha256sum] = "9897823a9d820ea011d9ea02054d5ab99469b9ca5346265fee380713c8fed27b"
32
33inherit autotools update-rc.d systemd pkgconfig
34
35PACKAGECONFIG ??= "tcp-wrappers"
36PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers"
37
38INITSCRIPT_NAME = "rpcbind"
39INITSCRIPT_PARAMS = "start 12 2 3 4 5 . stop 60 0 1 6 ."
40
41SYSTEMD_SERVICE_${PN} = "rpcbind.service"
42
43inherit useradd
44
45USERADD_PACKAGES = "${PN}"
46USERADD_PARAM_${PN} = "--system --no-create-home --home-dir / \
47 --shell /bin/false --user-group rpc"
48
49PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
50PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/, \
51 --without-systemdsystemunitdir, \
52 systemd \
53"
54
55EXTRA_OECONF += " --enable-warmstarts --with-rpcuser=rpc"
56
57do_install_append () {
58 mv ${D}${bindir} ${D}${sbindir}
59
60 install -d ${D}${sysconfdir}/init.d
61 sed -e 's,/etc/,${sysconfdir}/,g' \
62 -e 's,/sbin/,${sbindir}/,g' \
63 ${WORKDIR}/init.d > ${D}${sysconfdir}/init.d/rpcbind
64 chmod 0755 ${D}${sysconfdir}/init.d/rpcbind
65
66 install -m 0755 ${WORKDIR}/rpcbind.conf ${D}${sysconfdir}
67 install -d ${D}${systemd_unitdir}/system
68 install -m 0644 ${WORKDIR}/rpcbind.socket ${D}${systemd_unitdir}/system
69 install -m 0644 ${WORKDIR}/rpcbind.service ${D}${systemd_unitdir}/system
70 sed -i -e 's,@SBINDIR@,${sbindir},g' \
71 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
72 ${D}${systemd_unitdir}/system/rpcbind.service
73}