blob: 237e9f2526f30af559a58caec72c8abd998d5c85 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "The shared library for the S-Lang extension language"
2
3DESCRIPTION = "S-Lang is an interpreted language and a programming library. The \
4S-Lang language was designed so that it can be easily embedded into \
5a program to provide the program with a powerful extension language. \
6The S-Lang library, provided in this package, provides the S-Lang \
7extension language. S-Lang's syntax resembles C, which makes it easy \
8to recode S-Lang procedures in C if you need to."
9
10HOMEPAGE = "http://www.jedsoft.org/slang/"
11SECTION = "libs"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050012DEPENDS = "pcre ncurses"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050013PR = "r12"
14
15LICENSE = "GPLv2"
16LIC_FILES_CHKSUM = "file://COPYING;md5=a52a18a472d4f7e45479b06563717c02"
17
18
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050019SRC_URI = "http://www.jedsoft.org/releases/slang/old/slang-${PV}.tar.bz2 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050020 file://rpathfix.patch \
21 file://fix-check-pcre.patch \
22 file://change-char-type-to-signed-char-in-macros.patch \
23 file://sprintf-bug-concerning-8-bit-characters.patch \
24 file://slang-fix-the-iconv-existence-checking.patch \
25 file://0001-Fix-error-conflicting-types-for-posix_close.patch \
26 "
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050027UPSTREAM_CHECK_URI = "http://www.jedsoft.org/releases/slang/"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050028
29inherit autotools-brokensep
30
31CLEANBROKEN = "1"
32
33SRC_URI[md5sum] = "7fcfd447e378f07dd0c0bae671fe6487"
34SRC_URI[sha256sum] = "9a8257a9a2a55099af858b13338dc8f3a06dd2069f46f0df2c9c3bb84a01d5db"
35
36EXTRA_OECONF += " --without-z --without-png --without-onig --x-includes=${STAGING_DIR_HOST}/usr/include/X11 --x-libraries=${STAGING_DIR_HOST}/usr/lib"
37
38do_configure_prepend() {
39 # slang keeps configure.ac and rest of autoconf files in autoconf/ directory
40 # we have to go there to be able to run gnu-configize cause it expects configure.{in,ac}
41 # to be present. Resulting files land in autoconf/autoconf/ so we need to move them.
42 cd ${S}/autoconf && gnu-configize --force && mv autoconf/config.* .
43 cd ${B}
44}
45
46do_install() {
47 oe_runmake install DESTDIR=${D} -e 'INST_LIB_DIR=${STAGING_DIR_HOST}/usr/lib'
48}
49
50FILES_${PN} += "${libdir}/${BPN}/v2/modules/ ${datadir}/slsh/"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050051
52PARALLEL_MAKE = ""
53
54BBCLASSEXTEND = "native"