blob: a5ece074405de1980e6af2cb26ceca854c90e84a [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Command line file status display utility"
2DESCRIPTION = "Displays all information about a file that the stat() call provides and all information about a filesystem that statfs() provides."
3SECTION = "console/utils"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=39886b077fd072e876e5c4c16310b631 \
6 file://GPL;md5=94d55d512a9ba36caa9b7df079bae19f"
7
8SRC_URI = "http://www.ibiblio.org/pub/Linux/utils/file/${BP}.tar.gz \
9 file://fix-error-return.patch"
10
11SRC_URI[md5sum] = "37e247e8e400ad9205f1b0500b728fd3"
12SRC_URI[sha256sum] = "7071f0384a423a938dd542c1f08547a02824f6359acd3ef3f944b2c4c2d1ee09"
13
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050014EXTRA_OEMAKE = "-e MAKEFLAGS="
15
Patrick Williamsc124f4f2015-09-15 14:41:29 -050016do_install() {
17 install -d ${D}${base_bindir} ${D}${mandir}/man1
18 install -m 755 stat ${D}${base_bindir}/stat.stat
19 install -m 644 stat.1 ${D}${mandir}/man1
20}
21
22inherit update-alternatives
23
24ALTERNATIVE_${PN} = "stat"
25ALTERNATIVE_PRIORITY[stat] = "200"
26ALTERNATIVE_LINK_NAME[stat] = "${base_bindir}/stat"
27ALTERNATIVE_TARGET[stat] = "${base_bindir}/stat.stat"
28
29ALTERNATIVE_${PN}-doc = "stat.1"
30ALTERNATIVE_LINK_NAME[stat.1] = "${mandir}/man1/stat.1"
31
32BBCLASSEXTEND = "native"
33