blob: c1472cf97c6413e1a88dd5275e30bba7172f4150 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Basic desktop integration functions"
2
3DESCRIPTION = "The xdg-utils package is a set of simple scripts that provide basic \
4desktop integration functions for any Free Desktop, such as Linux. \
5They are intended to provide a set of defacto standards. \
6The following scripts are provided at this time: \
7xdg-desktop-icon \
8xdg-desktop-menu \
9xdg-email \
10xdg-icon-resource \
11xdg-mime \
12xdg-open \
13xdg-screensaver \
14xdg-terminal \
15"
16
17LICENSE = "MIT"
18LIC_FILES_CHKSUM = "file://LICENSE;md5=a5367a90934098d6b05af3b746405014"
19
20SRC_URI = "http://portland.freedesktop.org/download/${BPN}-${PV}.tar.gz \
21 file://0001-Reinstate-xdg-terminal.patch \
22 file://0001-Don-t-build-the-in-script-manual.patch \
23 "
24
25SRC_URI[md5sum] = "2d0aec6037769a5f138ff404b1bb4b15"
26SRC_URI[sha256sum] = "b0dd63a2576e0bb16f1aa78d6ddf7d6784784a098d4df17161cd6a17c7bc4125"
27
28UPSTREAM_CHECK_REGEX = "xdg-utils-(?P<pver>((\d+[\.\-_]*)+)((rc|alpha|beta)\d+)?)\.(tar\.gz|tgz)"
29
30inherit autotools-brokensep distro_features_check
31
32# The xprop requires x11 in DISTRO_FEATURES
33REQUIRED_DISTRO_FEATURES = "x11"
34
35DEPENDS = "xmlto-native libxslt-native"
36RDEPENDS_${PN} += "xprop"