blob: 9e9f714282a9a84382afa99e67f1d81cc489d4e2 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "GNOME configuration system"
2SECTION = "x11/gnome"
3LICENSE = "LGPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
5
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05006DEPENDS = "glib-2.0 dbus dbus-glib libxml2 intltool-native"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05007
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05008inherit gnomebase gtk-doc gettext gobject-introspection gio-module-cache
Patrick Williamsc124f4f2015-09-15 14:41:29 -05009
10SRC_URI = "${GNOME_MIRROR}/GConf/${@gnome_verdir("${PV}")}/GConf-${PV}.tar.xz;name=archive \
11 file://remove_plus_from_invalid_characters_list.patch \
12 file://unable-connect-dbus.patch \
13"
14
15SRC_URI[archive.md5sum] = "2b16996d0e4b112856ee5c59130e822c"
16SRC_URI[archive.sha256sum] = "1912b91803ab09a5eed34d364bf09fe3a2a9c96751fde03a4e0cfa51a04d784c"
17
18S = "${WORKDIR}/GConf-${PV}"
19
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050020EXTRA_OECONF = "--enable-shared --disable-static \
21 --disable-orbit --with-openldap=no --disable-gtk"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050022
23# Disable PolicyKit by default
24PACKAGECONFIG ??= ""
25# We really don't want PolicyKit for native or uclibc
26PACKAGECONFIG_class-native = ""
27PACKAGECONFIG_libc-uclibc = ""
28
29PACKAGECONFIG[policykit] = "--enable-defaults-service,--disable-defaults-service,polkit"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050030PACKAGECONFIG[debug] = "--enable-debug=yes, --enable-debug=minimum"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050031
32do_install_append() {
33 # this directory need to be created to avoid an Error 256 at gdm launch
34 install -d ${D}${sysconfdir}/gconf/gconf.xml.system
35
36 # this stuff is unusable
37 rm -f ${D}${libdir}/GConf/*/*.*a
38 rm -f ${D}${libdir}/gio/*/*.*a
39}
40
41do_install_append_class-native() {
42 create_wrapper ${D}/${bindir}/gconftool-2 \
43 GCONF_BACKEND_DIR=${STAGING_LIBDIR_NATIVE}/GConf/2
44}
45
Patrick Williamsc124f4f2015-09-15 14:41:29 -050046FILES_${PN} += "${libdir}/GConf/* \
47 ${libdir}/gio/*/*.so \
48 ${datadir}/polkit* \
49 ${datadir}/dbus-1/services/*.service \
50 ${datadir}/dbus-1/system-services/*.service \
51 "
Patrick Williamsc124f4f2015-09-15 14:41:29 -050052FILES_${PN}-dev += "${datadir}/sgml/gconf/gconf-1.0.dtd"
53
54BBCLASSEXTEND = "native"