blob: b427947a93d741cfbc64c509d2520f3897bd6445 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Generic font configuration library"
2DESCRIPTION = "Fontconfig is a font configuration and customization library, which \
3does not depend on the X Window System. It is designed to locate \
4fonts within the system and select them according to requirements \
5specified by applications. \
6Fontconfig is not a rasterization library, nor does it impose a \
7particular rasterization library on the application. The X-specific \
8library 'Xft' uses fontconfig along with freetype to specify and \
9rasterize fonts."
10
11HOMEPAGE = "http://www.fontconfig.org"
12BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=fontconfig"
13
14LICENSE = "MIT-style & MIT & PD"
15LIC_FILES_CHKSUM = "file://COPYING;md5=7a0449e9bc5370402a94c00204beca3d \
16 file://src/fcfreetype.c;endline=45;md5=5d9513e3196a1fbfdfa94051c09dfc84 \
17 file://src/fccache.c;beginline=1199;endline=1214;md5=0326cfeb4a7333dd4dd25fbbc4b9f27f"
18
19SECTION = "libs"
20
21DEPENDS = "expat freetype zlib"
22
23SRC_URI = "http://fontconfig.org/release/fontconfig-${PV}.tar.gz \
24 file://revert-static-pkgconfig.patch \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050025 file://0001-Revert-changes-made-to-FcConfigAppFontAddDir-recentl.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050026 "
27SRC_URI[md5sum] = "479be870c7f83f15f87bac085b61d641"
28SRC_URI[sha256sum] = "73f6d323c7bcfbde25d78397675191d55b8f4139132c6a9444410f3a2d8a9a95"
29
30PACKAGES =+ "fontconfig-utils"
31FILES_${PN} =+ "${datadir}/xml/*"
32FILES_fontconfig-utils = "${bindir}/*"
33
34# Work around past breakage in debian.bbclass
35RPROVIDES_fontconfig-utils = "libfontconfig-utils"
36RREPLACES_fontconfig-utils = "libfontconfig-utils"
37RCONFLICTS_fontconfig-utils = "libfontconfig-utils"
38DEBIAN_NOAUTONAME_fontconfig-utils = "1"
39
40inherit autotools pkgconfig
41
42FONTCONFIG_CACHE_DIR ?= "${localstatedir}/cache/fontconfig"
43
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050044# comma separated list of additional directories
45# /usr/share/fonts is already included by default (you can change it with --with-default-fonts)
46FONTCONFIG_FONT_DIRS ?= "no"
47
48EXTRA_OECONF = " --disable-docs --with-default-fonts=${datadir}/fonts --with-cache-dir=${FONTCONFIG_CACHE_DIR} --with-add-fonts=${FONTCONFIG_FONT_DIRS}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050049
50BBCLASSEXTEND = "native"