blob: 557b8c65db91d16669b750d4a8f16450297b3454 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Mesa demo applications"
2DESCRIPTION = "This package includes the demonstration application, such as glxgears. \
3These applications can be used for Mesa validation and benchmarking."
4HOMEPAGE = "http://mesa3d.org"
5BUGTRACKER = "https://bugs.freedesktop.org"
6SECTION = "x11"
7
8LICENSE = "MIT & PD"
9LIC_FILES_CHKSUM = "file://src/xdemos/glxgears.c;beginline=1;endline=20;md5=914225785450eff644a86c871d3ae00e \
10 file://src/xdemos/glxdemo.c;beginline=1;endline=8;md5=b01d5ab1aee94d35b7efaa2ef48e1a06"
11
12SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/demos/${PV}/${BPN}-${PV}.tar.bz2 \
13 file://0001-mesa-demos-Add-missing-data-files.patch \
14 file://0002-Correctly-implement-with-AC_WITH-glut-so-that-withou.patch \
15 file://0003-configure-Allow-to-disable-demos-which-require-GLEW-.patch \
16 file://0004-Use-DEMOS_DATA_DIR-to-locate-data-files.patch \
17 file://0005-Fix-build-when-EGL_MESA_screen_surface-extension-isn.patch \
18 file://0006-Query-display-for-EGL_MESA_screen_surface-extension-.patch \
19 file://0007-Install-few-more-test-programs.patch \
20 file://0008-glsl-perf-Add-few-missing-.glsl-.vert-.frag-files-to.patch \
21 file://0009-glsl-perf-Install-.glsl-.vert-.frag-files.patch \
Patrick Williamsf1e5d692016-03-30 15:21:19 -050022 file://0010-sharedtex_mt-fix-rendering-thread-hang.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050023"
24SRC_URI[md5sum] = "72613a2c8c013716db02e3ff59d29061"
25SRC_URI[sha256sum] = "e4bfecb5816ddd4b7b37c1bc876b63f1f7f06fda5879221a9774d0952f90ba92"
26
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050027inherit autotools pkgconfig distro_features_check
28# depends on virtual/egl, virtual/libgl ...
29REQUIRED_DISTRO_FEATURES = "opengl"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050030
31PACKAGECONFIG ?= "drm osmesa freetype2 gbm egl gles1 gles2 \
32 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 glew glu', '', d)}"
33
34# The Wayland code doesn't work with Wayland 1.0, so disable it for now
35#${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)}"
36
37EXTRA_OECONF = "--with-system-data-files"
38
39PACKAGECONFIG[drm] = "--enable-libdrm,--disable-libdrm,libdrm"
40PACKAGECONFIG[egl] = "--enable-egl,--disable-egl,virtual/egl"
41PACKAGECONFIG[freetype2] = "--enable-freetype2,--disable-freetype2,freetype"
42PACKAGECONFIG[gbm] = "--enable-gbm,--disable-gbm,virtual/libgl"
43PACKAGECONFIG[gles1] = "--enable-gles1,--disable-gles1,virtual/libgles1"
44PACKAGECONFIG[gles2] = "--enable-gles2,--disable-gles2,virtual/libgles2"
45PACKAGECONFIG[glut] = "--with-glut=${STAGING_EXECPREFIXDIR},--without-glut,"
46PACKAGECONFIG[osmesa] = "--enable-osmesa,--disable-osmesa,"
47PACKAGECONFIG[vg] = "--enable-vg,--disable-vg,virtual/libopenvg"
48PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,virtual/libgl wayland"
49PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11"
50PACKAGECONFIG[glew] = "--enable-glew,--disable-glew,glew"
51PACKAGECONFIG[glu] = "--enable-glu,--disable-glu,virtual/libgl"
52
53do_install_append() {
54 # it can be completely empty when all PACKAGECONFIG options are disabled
55 rmdir --ignore-fail-on-non-empty ${D}${bindir}
56
57 if [ -f ${D}${bindir}/clear ]; then
58 mv ${D}${bindir}/clear ${D}${bindir}/clear.mesa-demos
59 fi
60}