blob: b0264c3b38eeb5da643ab7c816f572cde404284a [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "An abstraction layer for touchscreen panel events"
2DESCRIPTION = "Tslib is an abstraction layer for touchscreen panel \
3events, as well as a filter stack for the manipulation of those events. \
4Tslib is generally used on embedded devices to provide a common user \
5space interface to touchscreen functionality."
6HOMEPAGE = "http://tslib.berlios.de/"
7
8AUTHOR = "Russell King w/ plugins by Chris Larson et. al."
9SECTION = "base"
10LICENSE = "LGPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=f30a9716ef3762e3467a2f62bf790f0a"
12
13SRC_URI = "https://github.com/kergoth/tslib/releases/download/${PV}/tslib-${PV}.tar.xz;downloadfilename=tslib-${PV}.tar.xz \
14 file://ts.conf \
15 file://tslib.sh \
16"
17
18SRC_URI[md5sum] = "14771f8607b341bb4b297819d37e837d"
19SRC_URI[sha256sum] = "fe35e5f710ea933b118f710e2ce4403ac076fe69926b570333867d4de082a51c"
20
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050021UPSTREAM_CHECK_URI = "https://github.com/kergoth/tslib/releases"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050022
23inherit autotools pkgconfig
24
25EXTRA_OECONF = "--enable-shared --disable-h3600 --enable-input --disable-corgi --disable-collie --disable-mk712 --disable-arctic2 --disable-ucb1x00"
26
27do_install_prepend() {
28 install -m 0644 ${WORKDIR}/ts.conf ${S}/etc/ts.conf
29}
30
31do_install_append() {
32 install -d ${D}${sysconfdir}/profile.d/
33 install -m 0755 ${WORKDIR}/tslib.sh ${D}${sysconfdir}/profile.d/
34}
35
36# People should consider using udev's /dev/input/touchscreen0 symlink
37# instead of detect-stylus
38#RDEPENDS_tslib-conf_weird-machine = "detect-stylus"
39RPROVIDES_tslib-conf = "libts-0.0-conf"
40
41PACKAGES =+ "tslib-conf tslib-tests tslib-calibrate"
42DEBIAN_NOAUTONAME_tslib-conf = "1"
43DEBIAN_NOAUTONAME_tslib-tests = "1"
44DEBIAN_NOAUTONAME_tslib-calibrate = "1"
45
46RDEPENDS_${PN} = "tslib-conf"
47RRECOMMENDS_${PN} = "pointercal"
48
Patrick Williamsc124f4f2015-09-15 14:41:29 -050049FILES_${PN}-dev += "${libdir}/ts/*.la"
50FILES_tslib-conf = "${sysconfdir}/ts.conf ${sysconfdir}/profile.d/tslib.sh ${datadir}/tslib"
51FILES_${PN} = "${libdir}/*.so.* ${libdir}/ts/*.so*"
52FILES_tslib-calibrate += "${bindir}/ts_calibrate"
53FILES_tslib-tests = "${bindir}/ts_harvest ${bindir}/ts_print ${bindir}/ts_print_raw ${bindir}/ts_test"