blob: d12ac186cd595b6ee853a5dc1202901730592e85 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Wayland, a protocol between a compositor and clients"
2DESCRIPTION = "Wayland is a protocol for a compositor to talk to its clients \
3as well as a C library implementation of that protocol. The compositor can be \
4a standalone display server running on Linux kernel modesetting and evdev \
5input devices, an X application, or a wayland client itself. The clients can \
6be traditional applications, X servers (rootless or fullscreen) or other \
7display servers."
8HOMEPAGE = "http://wayland.freedesktop.org"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b31d8f53b6aaf2b4985d7dd7810a70d1 \
11 file://src/wayland-server.c;endline=24;md5=b8e046164a766bb1ede8ba38e9dcd7ce"
12
13SRC_URI = "http://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz"
14SRC_URI[md5sum] = "5e141b3f2a7005d6c89d6f233c87c317"
15SRC_URI[sha256sum] = "9c8770720aa0034479735f58a4dc4ca9b172ecfede28f5134312e135b7301efa"
16
17EXTRA_OECONF_class-native = "--disable-documentation --disable-libraries"
18
19inherit autotools pkgconfig
20
21BBCLASSEXTEND = "native nativesdk"
22
23DEPENDS = "expat libffi wayland-native"
24
25EXTRA_OECONF = "--disable-documentation --with-host-scanner"
26
27# Wayland installs a M4 macro for other projects to use, which uses the target
28# pkg-config to find files. Replace pkg-config with pkg-config-native.
29do_install_append_class-native() {
30 sed -e 's,PKG_CHECK_MODULES(.*),,g' \
31 -e 's,$PKG_CONFIG,pkg-config-native,g' \
32 -i ${D}/${datadir}/aclocal/wayland-scanner.m4
33}
34
35sysroot_stage_all_append_class-target () {
36 rm ${SYSROOT_DESTDIR}/${datadir}/aclocal/wayland-scanner.m4
37 cp ${STAGING_DATADIR_NATIVE}/aclocal/wayland-scanner.m4 ${SYSROOT_DESTDIR}/${datadir}/aclocal/
38}
39
40FILES_${PN} = "${libdir}/*${SOLIBS}"
41FILES_${PN}-dev += "${bindir} ${datadir}/wayland"