blob: 6d7c347c001b2f0adb96be3ccd4f9a422c9bd773 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Common X11 scripts and configuration files"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
4SECTION = "x11"
5PR = "r47"
6
7inherit distro_features_check
8# rdepends on xdypinfo xmodmap xinit
9REQUIRED_DISTRO_FEATURES = "x11"
10
11SRC_URI = "file://etc \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050012 file://Xserver.in \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050013 file://gplv2-license.patch"
14
15S = "${WORKDIR}"
16
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050017PACKAGECONFIG ??= "blank"
18# dpms and screen saver will be on only if 'blank' is in PACKAGECONFIG
19PACKAGECONFIG[blank] = ""
20
Patrick Williamsc124f4f2015-09-15 14:41:29 -050021do_install() {
22 cp -R ${S}/etc ${D}${sysconfdir}
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050023 sed -e 's/@BLANK_ARGS@/${@bb.utils.contains('PACKAGECONFIG', 'blank', '', '-s 0 -dpms', d)}/' \
24 ${S}/Xserver.in > ${D}${sysconfdir}/X11/Xserver
25
Patrick Williamsc124f4f2015-09-15 14:41:29 -050026 chmod -R 755 ${D}${sysconfdir}
Patrick Williamsc124f4f2015-09-15 14:41:29 -050027}
28
29RDEPENDS_${PN} = "dbus-x11 xmodmap xdpyinfo xtscal xinit formfactor"
30