blob: 7ebb960f116fab0f0f5bc0e0fa7c07f0974adfb5 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001require xorg-driver-video.inc
2
3SUMMARY = "X.Org X server -- Texas Instruments OMAP framebuffer driver"
4
5DESCRIPTION = "omapfb driver supports the basic Texas Instruments OMAP \
6framebuffer."
7
8LICENSE = "MIT-X & GPLv2+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=63e2cbac53863f60e2f43343fb34367f"
10DEPENDS += "virtual/libx11"
11
12SRCREV = "33e36c12dde336edbdd34626dd8adfcaebc8fbb8"
13PR = "${INC_PR}.7"
14PV = "0.1.1+gitr${SRCPV}"
15
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050016# Blacklist debian-specific tags in upstream version check
17UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)(?!-)"
18
Patrick Williamsc124f4f2015-09-15 14:41:29 -050019SRC_URI = "git://anonscm.debian.org/collab-maint/xf86-video-omapfb.git \
20 file://0001-Prevents-omapfb-from-from-crashing-when-pixelclock-o.patch \
21 file://0001-Revert-Set-a-large-CRTC-upper-limit-to-not-prune-lar.patch \
22 file://0002-Revert-Set-virtual-size-when-configuring-framebuffer.patch \
23 file://0003-force-plain-mode.patch \
24 file://0004-blacklist-tv-out.patch \
25 file://0005-Attempt-to-fix-VRFB.patch \
26 file://0006-omapfb-port-to-new-xserver-video-API.patch \
27 file://0007-always_include_xorg_server.h.patch \
28"
29
30S = "${WORKDIR}/git"
31
Patrick Williamsc124f4f2015-09-15 14:41:29 -050032CFLAGS += " -I${STAGING_INCDIR}/xorg "
33
34# Use overlay 2 on omap3 to enable other apps to use overlay 1 (e.g. dmai or omapfbplay)
35do_compile_prepend_armv7a () {
36 sed -i -e s:fb1:fb2:g ${S}/src/omapfb-xv.c
37}