blob: 16a1f4f31eb7dbd3c69a949e1713420c16405d98 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Keyboard configuration database for X Window"
2
3DESCRIPTION = "The non-arch keyboard configuration database for X \
4Window. The goal is to provide the consistent, well-structured, \
5frequently released open source of X keyboard configuration data for X \
6Window System implementations. The project is targeted to XKB-based \
7systems."
8
9HOMEPAGE = "http://freedesktop.org/wiki/Software/XKeyboardConfig"
10BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=xkeyboard-config"
11
12LICENSE = "MIT & MIT-style"
13LIC_FILES_CHKSUM = "file://COPYING;md5=0e7f21ca7db975c63467d2e7624a12f9"
14
15SRC_URI = "${XORG_MIRROR}/individual/data/xkeyboard-config/${BPN}-${PV}.tar.bz2"
16SRC_URI[md5sum] = "bf6aa31195584cfce01b2194c3e5ea26"
17SRC_URI[sha256sum] = "1e8a1f212c96b7f71ca0b05da361cac1816d27baae1d8e03e7b53049b58d1d58"
18
19SECTION = "x11/libs"
20DEPENDS = "intltool-native virtual/gettext util-macros libxslt-native"
21
22EXTRA_OECONF = "--with-xkb-rules-symlink=xorg --disable-runtime-deps"
23
24FILES_${PN} += "${datadir}/X11/xkb"
25
26inherit autotools pkgconfig gettext
27
28do_install_append () {
29 install -d ${D}${datadir}/X11/xkb/compiled
30 cd ${D}${datadir}/X11/xkb/rules && ln -sf base xorg
31}