blob: 957cb7096f2ad5eb0448069b6860781a6e091ccf [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Generates traces of I/O traffic on block devices"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
4
5DEPENDS = "libaio"
6
7SRCREV = "43fc870ce04e963def45dfc0d1ed4ea21ef10d4b"
8
9PV = "1.1.0+git${SRCPV}"
10
11SRC_URI = "git://git.kernel.dk/blktrace.git \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050012 file://ldflags.patch \
13 file://0001-include-sys-types.h-for-dev_t-definition.patch \
14"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050015
16S = "${WORKDIR}/git"
17
18EXTRA_OEMAKE = "\
19 'CC=${CC}' \
20 'CFLAGS=${CFLAGS}' \
21 'LDFLAGS=${LDFLAGS}' \
22"
23
24# There are a few parallel issues:
25# 1) ../rbtree.o: error adding symbols: Invalid operation
26# collect2: error: ld returned 1 exit status
27# Makefile:42: recipe for target 'btt' failed
28# 2) git/blkiomon.c:216: undefined reference to `rb_insert_color'
29# collect2: error: ld returned 1 exit status
30# Makefile:27: recipe for target 'blkparse' failed
31# 3) ld: rbtree.o: invalid string offset 128 >= 125 for section `.strtab'
32# 4) btreplay.o: file not recognized: File truncated
33# collect2: error: ld returned 1 exit status
34# btreplay/btreplay.c:47:18: fatal error: list.h: No such file or directory
35PARALLEL_MAKE = ""
36
37do_install() {
38 oe_runmake ARCH="${ARCH}" prefix=${prefix} \
39 mandir=${mandir} DESTDIR=${D} install
40}
41