blob: 1f2dfb83dde2145916f990d7883c8ffbd4d2e88f [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Power usage tool"
2DESCRIPTION = "Linux tool to diagnose issues with power consumption and power management."
3HOMEPAGE = "http://01.org/powertop/"
4BUGTRACKER = "http://bugzilla.lesswatts.org/"
5DEPENDS = "ncurses libnl pciutils"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
8
9SRC_URI = "http://01.org/sites/default/files/downloads/powertop/powertop-${PV}.tar.gz \
10 file://0001-include-rquired-headers-for-typedefs.patch \
11"
12
13SRC_URI[md5sum] = "c55fedb69203e480801b18bd7b886241"
14SRC_URI[sha256sum] = "a87b563f73106babfa3e74dcf92f252938c061e309ace20a361358bbfa579c5a"
15
16UPSTREAM_CHECK_URI = "https://01.org/powertop/downloads"
17
18inherit autotools gettext pkgconfig
19
20# we need to explicitly link with libintl in uClibc systems
21EXTRA_LDFLAGS ?= ""
22EXTRA_LDFLAGS_libc-uclibc = "-lintl"
23LDFLAGS += "${EXTRA_LDFLAGS}"
24
25# we do not want libncursesw if we can
26do_configure_prepend() {
27 # configure.ac checks for delwin() in "ncursesw ncurses" so let's drop first one
28 sed -i -e "s/ncursesw//g" ${S}/configure.ac
29 mkdir -p ${B}/src/tuning/
30}
31
32inherit update-alternatives
33ALTERNATIVE_${PN} = "powertop"
34ALTERNATIVE_TARGET[powertop] = "${sbindir}/powertop"
35ALTERNATIVE_LINK_NAME[powertop] = "${sbindir}/powertop"
36ALTERNATIVE_PRIORITY = "100"