blob: ef6581b2ab6fc8f2edf98b05de710980179c7a24 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001DEFAULT_PREFERENCE = "-1"
2
3include gstreamer1.0-plugins-bad.inc
4
5LIC_FILES_CHKSUM = "file://COPYING;md5=73a5855a8119deb017f5f13cf327095d \
Patrick Williamsc124f4f2015-09-15 14:41:29 -05006 file://COPYING.LIB;md5=21682e4e8fea52413fd26c60acb907e5 \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05007 file://gst/tta/crc32.h;beginline=12;endline=29;md5=27db269c575d1e5317fffca2d33b3b50 \
8 file://gst/tta/filters.h;beginline=12;endline=29;md5=8a08270656f2f8ad7bb3655b83138e5a"
9
10SRC_URI = " \
11 git://anongit.freedesktop.org/gstreamer/gst-plugins-bad;name=base \
12 git://anongit.freedesktop.org/gstreamer/common;destsuffix=git/common;name=common \
13 file://configure-allow-to-disable-libssh2.patch \
14 file://fix-maybe-uninitialized-warnings-when-compiling-with-Os.patch \
15 file://avoid-including-sys-poll.h-directly.patch \
16 file://ensure-valid-sentinels-for-gst_structure_get-etc.patch \
17 file://0001-gstreamer-gl.pc.in-don-t-append-GL_CFLAGS-to-CFLAGS.patch \
18"
19
20PV = "1.7.2+git${SRCPV}"
21
22UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))"
23
24SRCREV_base = "50ae46cc0f8827bf966920d9c221e5cf86e811ba"
25SRCREV_common = "a25397448942079002622be231e9ec49b985745a"
26SRCREV_FORMAT = "base"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050027
28S = "${WORKDIR}/git"
29
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050030# over-ride the default hls PACKAGECONFIG in gstreamer1.0-plugins-bad.inc to
31# pass an additional --with-hls-crypto=XXX option (new in 1.7.x) and switch HLS
32# AES decryption from nettle to openssl (ie a shared dependency with dtls).
33# This should move back to the common .inc once the main recipe updates to 1.8.x
34PACKAGECONFIG[hls] = "--enable-hls --with-hls-crypto=openssl,--disable-hls,openssl"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050035
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050036# The tinyalsa plugin was added prior to the 1.7.2 release
37# https://cgit.freedesktop.org/gstreamer/gst-plugins-bad/commit/?id=c8bd74fa9a81398f57d976c478d2043f30188684
38PACKAGECONFIG[tinyalsa] = "--enable-tinyalsa,--disable-tinyalsa,tinyalsa"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050039
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050040# The vulkan based video sink plugin was added prior to the 1.7.2 release
41# https://cgit.freedesktop.org/gstreamer/gst-plugins-bad/commit/?id=5de6dd9f40629562acf90e35e1fa58464d66617d
42PACKAGECONFIG[vulkan] = "--enable-vulkan,--disable-vulkan,libxcb"
43
44# The dependency-less netsim plugin was added prior to the 1.7.2 release
45# https://cgit.freedesktop.org/gstreamer/gst-plugins-bad/commit/?id=e3f9e854f08e82bfab11182c5a2aa6f9a0c73cd5
Patrick Williamsc124f4f2015-09-15 14:41:29 -050046EXTRA_OECONF += " \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050047 --enable-netsim \
48"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050049
50do_configure_prepend() {
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050051 ${S}/autogen.sh --noconfigure
Patrick Williamsc124f4f2015-09-15 14:41:29 -050052}
53
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050054# In 1.6.2, the "--enable-hls" configure option generated an installable package
55# called "gstreamer1.0-plugins-bad-fragmented". In 1.7.1 that HLS plugin package
56# has become "gstreamer1.0-plugins-bad-hls". See:
57# http://cgit.freedesktop.org/gstreamer/gst-plugins-bad/commit/?id=efe62292a3d045126654d93239fdf4cc8e48ae08
58
59PACKAGESPLITFUNCS_append = " handle_hls_rename "
60
61python handle_hls_rename () {
62 d.setVar('RPROVIDES_gstreamer1.0-plugins-bad-hls', 'gstreamer1.0-plugins-bad-fragmented')
63 d.setVar('RREPLACES_gstreamer1.0-plugins-bad-hls', 'gstreamer1.0-plugins-bad-fragmented')
64 d.setVar('RCONFLICTS_gstreamer1.0-plugins-bad-hls', 'gstreamer1.0-plugins-bad-fragmented')
65}