blob: c89adac5dff76ac9a504eed4042f05d08076076f [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "WebP is an image format designed for the Web"
2DESCRIPTION = "WebP is a method of lossy and lossless compression that can be \
3 used on a large variety of photographic, translucent and \
4 graphical images found on the web. The degree of lossy \
5 compression is adjustable so a user can choose the trade-off \
6 between file size and image quality. WebP typically achieves \
7 an average of 30% more compression than JPEG and JPEG 2000, \
8 without loss of image quality."
9HOMEPAGE = "https://developers.google.com/speed/webp/"
10SECTION = "libs"
11
12LICENSE = "BSD"
13LIC_FILES_CHKSUM = "file://COPYING;md5=6e8dee932c26f2dab503abf70c96d8bb \
14 file://PATENTS;md5=c6926d0cb07d296f886ab6e0cc5a85b7"
15
16SRC_URI = "http://downloads.webmproject.org/releases/webp/${BP}.tar.gz"
17SRC_URI[md5sum] = "ba81eb9bf23e3c69a2f5cc8dcdb5938f"
18SRC_URI[sha256sum] = "5cd3bb7b623aff1f4e70bd611dc8dbabbf7688fd5eb225b32e02e09e37dfb274"
19
20UPSTREAM_CHECK_URI = "http://downloads.webmproject.org/releases/webp/index.html"
21
22EXTRA_OECONF = " \
23 --disable-experimental \
24 --disable-wic \
25 --enable-libwebpmux \
26 --enable-libwebpdemux \
27 --enable-threading \
28"
29
30inherit autotools lib_package
31
32PACKAGECONFIG ??= ""
33
34# libwebpdecoder is a subset of libwebp, don't build it unless requested
35PACKAGECONFIG[decoder] = "--enable-libwebpdecoder,--disable-libwebpdecoder"
36
37# Apply for examples programs: cwebp and dwebp
38PACKAGECONFIG[gif] = "--enable-gif,--disable-gif,giflib"
39PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg"
40PACKAGECONFIG[png] = "--enable-png,--disable-png,,libpng"
41PACKAGECONFIG[tiff] = "--enable-tiff,--disable-tiff,tiff"
42
43# Apply only for example program vwebp
44PACKAGECONFIG[gl] = "--enable-gl,--disable-gl,mesa-glut"
45
46PACKAGES =+ "${PN}-gif2webp"
47
48DESCRIPTION_${PN}-gif2webp = "Simple tool to convert animated GIFs to WebP"
49FILES_${PN}-gif2webp = "${bindir}/gif2webp"