blob: 962069e3dc71d044c143afe85eab8b883b8f77b5 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Hardware latency detector"
2DESCRIPTION = "Python utility for controlling the kernel hardware latency detection module (hwlat_detector.ko)."
3HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest"
4SECTION = "tests"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
7
8require rt-tests.inc
9
10EXTRA_OEMAKE += "PYLIB=${libdir}/python${PYTHON_BASEVERSION}/dist-packages"
11
12do_compile() {
13 oe_runmake hwlatdetect
14}
15
16do_install() {
17 oe_runmake install_hwlatdetect DESTDIR=${D} SBINDIR=${sbindir} \
18 MANDIR=${mandir} INCLUDEDIR=${includedir}
19}
20
21FILES_${PN} += "${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py"
22RDEPENDS_${PN} = "python python-subprocess python-textutils"
23RRECOMMENDS_${PN} = "kernel-module-hwlat-detector"