blob: dbe8c11451c43555f45102144c1f3d3ae65700fb [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Matchbox Window Manager Desktop"
2HOMEPAGE = "http://matchbox-project.org/"
3BUGTRACKER = "http://bugzilla.yoctoproject.org/"
4
5LICENSE = "GPLv2+ & LGPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://libtaku/eggsequence.h;endline=20;md5=b91f68f7642a1459fa1f4c9df94a8f15 \
8 file://src/desktop.c;endline=20;md5=36c9bf295e6007f3423095f405af5a2d \
9 file://src/main.c;endline=19;md5=2044244f97a195c25b7dc602ac7e9a00"
10
11DEPENDS = "gtk+ startup-notification dbus"
12SECTION = "x11/wm"
13SRCREV = "71e3e6e04271e9d5a14f1c231ef100c7f320134d"
14PV = "2.0+git${SRCPV}"
15
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050016SRC_URI = "git://git.yoctoproject.org/${BPN}-2 \
17 file://0001-Do-nothing-on-delete-event-when-not-STANDALONE.patch \
18 "
Patrick Williamsc124f4f2015-09-15 14:41:29 -050019
20EXTRA_OECONF = "--enable-startup-notification --with-dbus"
21
22S = "${WORKDIR}/git"
23
24inherit autotools pkgconfig distro_features_check
25
26# The startup-notification requires x11 in DISTRO_FEATURES
27REQUIRED_DISTRO_FEATURES = "x11"