blob: 8d4dab399b91cebe7bf322cf0c9a689e14bafe9b [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "A garbage collector for C and C++"
2
3DESCRIPTION = "The Boehm-Demers-Weiser conservative garbage collector can be\
4 used as a garbage collecting replacement for C malloc or C++ new. It allows\
5 you to allocate memory basically as you normally would, without explicitly\
6 deallocating memory that is no longer useful. The collector automatically\
7 recycles memory when it determines that it can no longer be otherwise\
8 accessed.\
9 The collector is also used by a number of programming language\
10 implementations that either use C as intermediate code, want to facilitate\
11 easier interoperation with C libraries, or just prefer the simple collector\
12 interface.\
13 Alternatively, the garbage collector may be used as a leak detector for C\
14 or C++ programs, though that is not its primary goal.\
15 Empirically, this collector works with most unmodified C programs, simply\
16 by replacing malloc with GC_malloc calls, replacing realloc with GC_realloc\
17 calls, and removing free calls."
18
19HOMEPAGE = "http://www.hboehm.info/gc/"
20SECTION = "devel"
21LICENSE = "MIT"
22LIC_FILES_CHKSUM = "file://README.QUICK;md5=55f5088f90a982fed7af9a4897047ef7"
23
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050024SRCREV = "e31cdc288ffbee5bf25f948e19deb5a7ce846971"
25SRC_URI = "git://github.com/ivmai/bdwgc.git;branch=release-7_4 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050026 file://0001-fix-build-with-musl.patch \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050027 file://0001-configure.ac-add-check-for-NO_GETCONTEXT-definition.patch \
28 file://0002-Altera-NIOS2-support.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050029 "
30
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050031FILES_${PN}-doc = "${datadir}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050032
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050033S = "${WORKDIR}/git"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050034
35ARM_INSTRUCTION_SET = "arm"
36
37inherit autotools pkgconfig
38
39# by default use external libatomic-ops
40PACKAGECONFIG ??= "libatomic-ops"
41PACKAGECONFIG[libatomic-ops] = "--with-libatomic-ops=yes,--with-libatomic-ops=no,libatomic-ops"
42
43BBCLASSEXTEND = "native nativesdk"