blob: 6a1d5bf83d450acd801aae3a8e45346e6182b534 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Miscellaneous utilities specific to Debian"
2SECTION = "base"
3LICENSE = "GPLv2 & SMAIL_GPL"
4LIC_FILES_CHKSUM = "file://debian/copyright;md5=f01a5203d50512fc4830b4332b696a9f"
5
6SRC_URI = "http://snapshot.debian.org/archive/debian/20160204T040501Z/pool/main/d/${BPN}/${BPN}_${PV}.tar.xz"
7# the package is taken from snapshots.debian.org; that source is static and goes stale
8# so we check the latest upstream from a directory that does get updated
9UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/d/${BPN}/"
10
11SRC_URI[md5sum] = "00186f527b35e2cecd4db593c6d512d0"
12SRC_URI[sha256sum] = "a269cacd40f52f2fa5d5636357714a49e8538459c16d77772efaa23711fe53d9"
13
14inherit autotools update-alternatives
15
16do_configure_prepend() {
17 sed -i -e 's:tempfile.1 which.1:which.1:g' ${S}/Makefile.am
18}
19
20do_install_append() {
21 if [ "${base_bindir}" != "${bindir}" ]; then
22 # Debian places some utils into ${base_bindir} as does busybox
23 install -d ${D}${base_bindir}
24 for app in run-parts tempfile; do
25 mv ${D}${bindir}/$app ${D}${base_bindir}/$app
26 done
27 fi
28}
29
30# Note that we package the update-alternatives name.
31#
32PACKAGES =+ "${PN}-run-parts"
33FILES_${PN}-run-parts = "${base_bindir}/run-parts.debianutils"
34
35RDEPENDS_${PN} += "${PN}-run-parts"
36
37
38ALTERNATIVE_PRIORITY="30"
39ALTERNATIVE_${PN} = "add-shell installkernel remove-shell savelog tempfile which"
40ALTERNATIVE_${PN}-run-parts = "run-parts"
41
42ALTERNATIVE_LINK_NAME[add-shell]="${sbindir}/add-shell"
43ALTERNATIVE_LINK_NAME[installkernel]="${sbindir}/installkernel"
44ALTERNATIVE_LINK_NAME[remove-shell]="${sbindir}/remove-shell"
45ALTERNATIVE_LINK_NAME[run-parts]="${base_bindir}/run-parts"
46ALTERNATIVE_LINK_NAME[savelog]="${bindir}/savelog"
47ALTERNATIVE_LINK_NAME[tempfile]="${base_bindir}/tempfile"
48ALTERNATIVE_LINK_NAME[which]="${bindir}/which"