blob: 3335386d8fda79a2fc8661f8ea7db9602b8a9fd8 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001# Copyright (C) 2013 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Library of utility functions from BSD systems"
5DESCRIPTION = "This library provides useful functions commonly found on BSD systems, \
6 and lacking on others like GNU systems, thus making it easier to port \
7 projects with strong BSD origins, without needing to embed the same \
8 code over and over again on each project."
9
10HOMEPAGE = "http://libbsd.freedesktop.org/wiki/"
11# There seems to be more licenses used in the code, I don't think we want to list them all here, complete list:
12# OE @ ~/projects/libbsd $ grep ^License: COPYING | sort
13# License: BSD-2-clause
14# License: BSD-2-clause
15# License: BSD-2-clause-NetBSD
16# License: BSD-2-clause-author
17# License: BSD-2-clause-verbatim
18# License: BSD-3-clause
19# License: BSD-3-clause
20# License: BSD-3-clause
21# License: BSD-3-clause-Peter-Wemm
22# License: BSD-3-clause-Regents
23# License: BSD-4-clause-Christopher-G-Demetriou
24# License: BSD-4-clause-Niels-Provos
25# License: BSD-5-clause-Peter-Wemm
26# License: Beerware
27# License: Expat
28# License: ISC
29# License: ISC-Original
30# License: public-domain
31# License: public-domain-Colin-Plumb
32LICENSE = "BSD-4-Clause & ISC & PD"
33LIC_FILES_CHKSUM = "file://COPYING;md5=145ec05a217d8f879f29cfc5f83084be"
34SECTION = "libs"
35
36SRC_URI = " \
37 http://libbsd.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
38"
39
40SRC_URI[md5sum] = "cdee252ccff978b50ad2336278c506c9"
41SRC_URI[sha256sum] = "b2f644cae94a6e2fe109449c20ad79a0f6ee4faec2205b07eefa0020565e250a"
42
43inherit autotools pkgconfig