blob: 72e25fb9d5f3248b4174071b89a0378562ac4c94 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "A portable foreign function interface library"
2DESCRIPTION = "The `libffi' library provides a portable, high level programming interface to various calling \
3conventions. This allows a programmer to call any function specified by a call interface description at run \
4time. FFI stands for Foreign Function Interface. A foreign function interface is the popular name for the \
5interface that allows code written in one language to call code written in another language. The `libffi' \
6library really only provides the lowest, machine dependent layer of a fully featured foreign function interface. \
7A layer must exist above `libffi' that handles type conversions for values passed between the two languages."
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=3610bb17683a0089ed64055416b2ae1b"
11
12SRC_URI = "ftp://sourceware.org/pub/libffi/${BP}.tar.gz \
13 file://not-win32.patch \
14 file://0001-mips-Use-compiler-internal-define-for-linux.patch \
15 "
16
17SRC_URI[md5sum] = "83b89587607e3eb65c70d361f13bab43"
18SRC_URI[sha256sum] = "d06ebb8e1d9a22d19e38d63fdb83954253f39bedc5d46232a05645685722ca37"
19
20EXTRA_OECONF += "--disable-builddir"
21
22inherit autotools texinfo
23
24FILES_${PN}-dev += "${libdir}/libffi-${PV}"
25
26BBCLASSEXTEND = "native nativesdk"