blob: 0dd16025af942ebb6e1f4bcf76a043665aa2b51f [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Small library that defines common error values for all GnuPG components"
2HOMEPAGE = "http://www.gnupg.org/related_software/libgpg-error/"
3BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
4
5LICENSE = "GPLv2+ & LGPLv2.1+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
7 file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \
8 file://src/gpg-error.h.in;endline=23;md5=93d3155af141ae3b369a5d09ca9d6234 \
9 file://src/init.c;endline=20;md5=8f5a9b59634f4aebcd0ec9d3ebd53bfe"
10
11
12SECTION = "libs"
13
14SRC_URI = "ftp://ftp.gnupg.org/gcrypt/libgpg-error/libgpg-error-${PV}.tar.bz2 \
15 file://pkgconfig.patch \
16 file://0001-libgpg-error-Add-nios2-support.patch \
17 "
18SRC_URI[md5sum] = "ab0b5aba6d0a185b41d07bda804fd8b2"
19SRC_URI[sha256sum] = "b7dbdb3cad63a740e9f0c632a1da32d4afdb694ec86c8625c98ea0691713b84d"
20
21BINCONFIG = "${bindir}/gpg-error-config"
22
23inherit autotools binconfig-disabled pkgconfig gettext
24CPPFLAGS += "-P"
25do_compile_prepend() {
26 TARGET_FILE=linux-gnu
27 if [ ${TARGET_OS} != "linux" ]; then
28 TARGET_FILE=${TARGET_OS}
29 fi
30
31 case ${TARGET_ARCH} in
32 aarch64_be) TUPLE=aarch64-unknown-linux-gnu ;;
33 arm) TUPLE=arm-unknown-linux-gnueabi ;;
34 armeb) TUPLE=arm-unknown-linux-gnueabi ;;
35 i586|i686) TUPLE=i686-pc-linux-gnu ;;
36 mips64el) TUPLE=mipsel-unknown-linux-gnu ;;
37 mips64) TUPLE=mips-unknown-linux-gnu ;;
38 x86_64) TUPLE=x86_64-pc-linux-gnu ;;
39 *) TUPLE=${TARGET_ARCH}-unknown-linux-gnu ;;
40 esac
41
42 cp ${S}/src/syscfg/lock-obj-pub.$TUPLE.h \
43 ${S}/src/syscfg/lock-obj-pub.$TARGET_FILE.h
44}
45
46do_install_append() {
47 # we don't have common lisp in OE
48 rm -rf "${D}${datadir}/common-lisp/"
49}
50
51FILES_${PN}-dev += "${bindir}/gpg-error"
52
53BBCLASSEXTEND = "native"