blob: 23ac599de513ea239ed0d70495ee4ea25bc74cbc [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "GNOME XSLT library"
2HOMEPAGE = "http://xmlsoft.org/XSLT/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458"
7
8SECTION = "libs"
9DEPENDS = "libxml2"
10
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050011SRC_URI = "ftp://xmlsoft.org/libxslt/libxslt-${PV}.tar.gz \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050012 file://pkgconfig_fix.patch \
Patrick Williamsf1e5d692016-03-30 15:21:19 -050013 file://pkgconfig.patch \
14 file://CVE-2015-7995.patch"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050015
16SRC_URI[md5sum] = "9667bf6f9310b957254fdcf6596600b7"
17SRC_URI[sha256sum] = "5fc7151a57b89c03d7b825df5a0fae0a8d5f05674c0e7cf2937ecec4d54a028c"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050018
19UPSTREAM_CHECK_REGEX = "libxslt-(?P<pver>\d+(\.\d+)+)\.tar"
20
Patrick Williamsc124f4f2015-09-15 14:41:29 -050021S = "${WORKDIR}/libxslt-${PV}"
22
23BINCONFIG = "${bindir}/xslt-config"
24
25inherit autotools pkgconfig binconfig-disabled lib_package
26
27# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
28do_configure_prepend () {
29 sed -i -e 's/ansidecl.h//' ${S}/configure.in
30
31 # The timestamps in the 1.1.28 tarball are messed up causing this file to
32 # appear out of date. Touch it so that we don't try to regenerate it.
33 touch ${S}/doc/xsltproc.1
34}
35
36EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
37# older versions of this recipe had ${PN}-utils
38RPROVIDES_${PN}-bin += "${PN}-utils"
39RCONFLICTS_${PN}-bin += "${PN}-utils"
40RREPLACES_${PN}-bin += "${PN}-utils"
41
42
43do_install_append_class-native () {
44 create_wrapper ${D}/${bindir}/xsltproc XML_CATALOG_FILES=${sysconfdir}/xml/catalog.xml
45}
46
47FILES_${PN} += "${libdir}/libxslt-plugins"
48FILES_${PN}-dev += "${libdir}/xsltConf.sh"
49
50BBCLASSEXTEND = "native nativesdk"